summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVitalii Kuzhdin2025-01-12 20:31:52 +0100
committerVitalii Kuzhdin2025-01-12 20:31:52 +0100
commit474a2194adaf765a4b569dd235dd3b05f51ed17e (patch)
tree669877f381e38cb076f7ffbf565026d67ad82e54 /PKGBUILD
parent5e230e39b7ef7ba2f01242c1caa93afb88de8e28 (diff)
downloadaur-474a2194adaf765a4b569dd235dd3b05f51ed17e.tar.gz
Fix meson build dir
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53e7357ce9b9..9f367bef58f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@ pkgrel=1
pkgdesc="C++ bindings for ATK (32-bit)"
url="https://www.gtkmm.org"
arch=('x86_64')
-license=(LGPL-2.1-or-later)
-depends=("${_name}" 'lib32-at-spi2-core' 'lib32-glib2' 'lib32-gcc-libs'
- 'lib32-glibc' 'lib32-glibmm' 'lib32-libsigc++')
+license=('LGPL-2.1-or-later')
+depends=("${_name}" 'lib32-at-spi2-core>=2.12' 'lib32-glib2' 'lib32-gcc-libs'
+ 'lib32-glibc' 'lib32-glibmm>=2.46.2' 'lib32-libsigc++')
makedepends=('meson>=0.55' 'mm-common')
-provides=('libatkmm-1.6.so')
+provides=("lib${_name}-1.6.so")
_pkgsrc="${_name}-${pkgver}"
source=("${_pkgsrc}.tar.xz::https://download.gnome.org/sources/${_name}/${pkgver%.*}/${_pkgsrc}.tar.xz")
sha256sums=('0a142a8128f83c001efb8014ee463e9a766054ef84686af953135e04d28fdab3')
@@ -23,16 +23,16 @@ build() {
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
cd "${srcdir}"
- arch-meson "${_pkgsrc}" build \
+ arch-meson "${_pkgsrc}" "${_pkgsrc}/build" \
--cross-file lib32 \
-D maintainer-mode=true \
-D build-documentation=false
- meson compile -C build
+ meson compile -C "${_pkgsrc}/build"
}
package() {
cd "${srcdir}"
- meson install -C build --destdir "${pkgdir}"
+ meson install -C "${_pkgsrc}/build" --destdir "${pkgdir}"
cd "${pkgdir}/usr"
rm -rf "include"