summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Demers2022-01-07 18:52:30 -0500
committerAlexandre Demers2022-01-07 18:52:30 -0500
commit15724a3479991cd82434d1d08cc26af0a6cb09da (patch)
treed31a399fe60cd4fde4c7b7e25efcacbfae191212 /PKGBUILD
parentacb5bc44b35a3a897b8ccb875550561be8c7362d (diff)
downloadaur-15724a3479991cd82434d1d08cc26af0a6cb09da.tar.gz
Add a workaround for Meson's underscore detection (c6a08b3aa1ee99dade53e5e32033bc1d14455a22)
While I didn't have any issue personally, a issue reported by Nocifer may be fixed by it. This fix should be included in the next dav1d release, so this is a workaround for the time being. Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 919ce1937e68..9bcb67d44433 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbasename=dav1d
pkgname=("lib32-$_pkgbasename" "lib32-lib$_pkgbasename")
pkgver=0.9.2
-pkgrel=1
+pkgrel=2
pkgdesc='AV1 cross-platform decoder focused on speed and correctness (32 bit)'
url='https://code.videolan.org/videolan/dav1d/'
arch=('x86_64')
@@ -19,14 +19,17 @@ makedepends=(
)
source=(
https://downloads.videolan.org/pub/videolan/${_pkgbasename}/${pkgver}/${_pkgbasename}-${pkgver}.tar.xz{,.asc}
+ "https://code.videolan.org/videolan/dav1d/-/commit/c6a08b3aa1ee99dade53e5e32033bc1d14455a22.patch"
)
sha512sums=(
'87026f8b14e408ff50fc8f137ec2ede4b14c5f69687e615d2359d0f718ae5cb5176522490786d9ae1f7838182f82615c2674f7c2961b6dcec83f1ee587c3af7c'
'SKIP'
+ 'SKIP'
)
b2sums=(
'7baa28821b06b05b95d3ea80b22dffe59d0793c9b4be4231ba0be99b548e1f5517a956dc865c2be1702576d078c2218e7e80342a26ab4003b4f06bcb0cdbb769'
'SKIP'
+ 'SKIP'
)
validpgpkeys=('65F7C6B4206BD057A7EB73787180713BE58D1ADC') # VideoLAN Release Signing Key
@@ -34,6 +37,8 @@ prepare() {
cd ${_pkgbasename}-${pkgver}
# Patching if needed
+ echo "Patching meson.build"
+ patch -p1 < ../c6a08b3aa1ee99dade53e5e32033bc1d14455a22.patch
}
build() {