summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072021-09-18 12:07:18 +0200
committersL1pKn072021-09-18 12:07:18 +0200
commitc2000ebe39378618687506c6c9db278c2ef9959a (patch)
tree42348ea28065a56bcc96d18b054c794c52c2aad3 /PKGBUILD
parent9706c8031ef22ff476436d951c1161e819e64f65 (diff)
downloadaur-c2000ebe39378618687506c6c9db278c2ef9959a.tar.gz
update to 1.1.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 28 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 419dcbc095fa..b7bc557512ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,27 @@
# Maintainer: Andrew Sun <adsun701 at gmail dot com>
-_basename=egl-wayland
-pkgname="lib32-$_basename"
-pkgver=1.1.6
+pkgname='lib32-egl-wayland'
+pkgver=1.1.8
pkgrel=1
-pkgdesc="EGLStream-based Wayland external platform (32-bit)"
-arch=(x86_64)
-url=https://github.com/NVIDIA/egl-wayland
-license=(MIT)
-depends=('lib32-wayland' 'eglexternalplatform' "$_basename")
-makedepends=('meson' 'git')
-options=(!emptydirs)
-_commit=1b0f2b8dd906c82d20de45974f81295fda9f2bd0 # tags/1.1.6
-source=("git+$url#commit=$_commit")
+pkgdesc='EGLStream-based Wayland external platform (32-bit)'
+arch=('x86_64')
+url='https://github.com/NVIDIA/egl-wayland'
+license=('MIT')
+depends=('lib32-wayland'
+ "egl-wayland=${pkgver}"
+ )
+makedepends=('meson'
+ 'git'
+ 'lib32-libglvnd'
+ )
+provides=('libnvidia-egl-wayland.so')
+options=('!emptydirs')
+source=("git+https://github.com/NVIDIA/egl-wayland#tag=$pkgver")
sha256sums=('SKIP')
pkgver() {
- cd $_basename
- git describe --tags | sed 's/-/+/g'
+ cd egl-wayland
+ echo $(git describe --tags | tr - +)
}
prepare() {
@@ -29,11 +33,18 @@ build() {
export CXX="g++ -m32"
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
- arch-meson ${_basename} build --libdir=/usr/lib32
+ arch-meson egl-wayland build \
+ --libdir=/usr/lib32
+
ninja -C build
}
package() {
- DESTDIR="$pkgdir" meson install -C build
- rm -rf "$pkgdir"/usr/{include,share,bin}
+ DESTDIR="${pkgdir}" meson install -C build
+
+ rm -rf "${pkgdir}/usr/include"
+ rm -rf "${pkgdir}/usr/share"
+ rm -rf "${pkgdir}/usr/bin"
+
+ install -Dm644 egl-wayland/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}