summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072022-02-08 16:00:29 +0100
committersL1pKn072022-02-08 16:00:29 +0100
commitccd03c8e76c93499a9746fd6f0605c3140f8b64c (patch)
tree4c0465a8f9683bf9e76c8f4d5733bfc5e5187d60 /PKGBUILD
parentd88b5a11edc730c536bd378eedcf524cbbbe62c0 (diff)
downloadaur-ccd03c8e76c93499a9746fd6f0605c3140f8b64c.tar.gz
Update to 1.1.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70a5cfd6e083..0eb0749aeabf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Andrew Sun <adsun701 at gmail dot com>
pkgname='lib32-egl-wayland'
-pkgver=1.1.7
+pkgver=1.1.9+r3+g582b2d3
pkgrel=1
pkgdesc='EGLStream-based Wayland external platform (32-bit)'
arch=('x86_64')
url='https://github.com/NVIDIA/egl-wayland'
license=('MIT')
depends=('lib32-wayland'
- "egl-wayland=1:${pkgver}"
+ "egl-wayland=2:${pkgver}"
)
makedepends=('meson'
'git'
@@ -16,12 +16,13 @@ makedepends=('meson'
)
provides=('libnvidia-egl-wayland.so')
options=('!emptydirs')
-source=("git+https://github.com/NVIDIA/egl-wayland#tag=$pkgver")
+source=("git+https://github.com/NVIDIA/egl-wayland#commit=582b2d345abaa0e313cf16c902e602084ea59551")
sha256sums=('SKIP')
pkgver() {
cd egl-wayland
- echo $(git describe --tags | tr - +)
+# echo $(git describe --tags | tr - +)
+ echo "$(git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g')"
}
prepare() {
@@ -36,7 +37,11 @@ build() {
arch-meson egl-wayland build \
--libdir=/usr/lib32
- ninja -C build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
}
package() {