summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2019-11-23 12:52:07 -0500
committerAndrew Sun2019-11-23 12:52:07 -0500
commitd638f3a96fec4083b3a749a021fba75e02d9dee8 (patch)
tree9f56585eaa888f357e4a28452704b9e2d5582627 /PKGBUILD
parent86d5ae156aa58d06e67d5e1c4906ceaac66418f3 (diff)
downloadaur-d638f3a96fec4083b3a749a021fba75e02d9dee8.tar.gz
fix build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a77c85a62943..04bdb40fad12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_basename=egl-wayland
pkgname="lib32-$_basename"
pkgver=1.1.4
-pkgrel=1
+pkgrel=2
pkgdesc="EGLStream-based Wayland external platform (32-bit)"
arch=(x86_64)
url=https://github.com/NVIDIA/egl-wayland
@@ -11,9 +11,11 @@ license=(MIT)
depends=('lib32-wayland' 'eglexternalplatform' "$_basename")
makedepends=('meson' 'git')
options=(!emptydirs)
-_commit=0c8e822cccff8f4ed472a7b6ac26a215ad13abc4 # tags/1.1.4
-source=("git+$url#commit=$_commit")
-sha256sums=('SKIP')
+_commit=47d96a84b04d21cd0a2f23b59a4936c829a65364 # tags/1.1.4
+source=("git+$url#commit=$_commit"
+ glvnd.diff)
+sha256sums=('SKIP'
+ 'e6d965551829448ffc2ea0fdf97d7d44c3d35be0b56fc025e6cc343f29f7b9d6')
pkgver() {
cd $_basename
@@ -22,6 +24,9 @@ pkgver() {
prepare() {
cd $_basename
+
+ # Fix build with headers from libglvnd
+ git apply -3 ../glvnd.diff
}
build() {