summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexey D2014-09-14 09:41:47 +0400
committerAlexey D2015-07-05 10:58:47 +0300
commit5dab8a0762739068825dad8cdbbc5616a95a22da (patch)
tree257ee579c48f607d7eceacc1351bd420cee84edc /PKGBUILD
parentbeb1b66e9ddba44bb409a9788857230c689c8738 (diff)
downloadaur-5dab8a0762739068825dad8cdbbc5616a95a22da.tar.gz
version 20140913-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1b920c827a4..4161d40f3cce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,13 @@
# Contributor: Ivailo Monev <xakepa10@gmail.com>
pkgname='lib32-eudev-git'
pkgdesc="The userspace dev tools (udev) forked by Gentoo (32-bit)"
-pkgver=20140315
+pkgver=20140913
pkgrel=1
-_udevver=210
arch=('x86_64')
url="https://github.com/gentoo/eudev"
license=('GPL')
depends=('lib32-glib2' 'eudev-git')
makedepends=('git' 'gcc-multilib' 'lib32-util-linux' 'gobject-introspection' 'gperf')
-provides=("lib32-systemd=${_udevver}")
replaces=('lib32-systemd')
conflicts=('lib32-systemd')
options=(!makeflags !libtool)
@@ -38,9 +36,6 @@ build() {
make clean
fi
- # Temporary workaround for bug #87
- #sed /"#include <linux\/fcntl.h>"/d -i src/*/*.c
-
msg2 "Configuring sources..."
./autogen.sh
./configure --prefix=/usr \
@@ -48,7 +43,6 @@ build() {
--sysconfdir=/etc \
--libdir=/usr/lib32 \
--sbindir=/usr/bin \
- --with-firmware-path=/usr/lib/firmware/updates:/lib/firmware/updates:/usr/lib/firmware:/lib/firmware \
--with-modprobe=/usr/bin/modprobe \
--enable-gudev \
--enable-introspection \
@@ -65,5 +59,9 @@ package() {
rm -rf "${pkgdir}"/etc
rm -rf "${pkgdir}"/usr/{bin,include,lib,share}
+
+ # Getting udev version
+ udevver=$(grep UDEV_VERSION configure.ac | egrep -o "[0-9]{3}")
+ provides+=("lib32-systemd=${udevver}")
}