summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Demers2020-06-21 22:45:42 -0400
committerAlexandre Demers2020-06-21 22:45:42 -0400
commite22cead08c28e7bfc666414ed4e363b597f21f38 (patch)
treedadc7247520092849fd39d20049cfd983e9929d6 /PKGBUILD
parent1d6fd3d677b6db6d31af12908c41cfd5e88e4676 (diff)
downloadaur-e22cead08c28e7bfc666414ed4e363b597f21f38.tar.gz
Split libraries from executables, rebuild against latest x265 and aom
Most peolple don't need the executables. Let's split libraries from the executables in two different packages as done in other distro. If needed, one can install lib32-ffmpeg to mimic exactly what is done by the ffmpeg package. Rebuild against latest x265 and aom. We are not moving to 4.3 yet, since a major bug was reported with chromium and others. Until it is fixed, we'll stay under the 4.2 branch. Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD201
1 files changed, 134 insertions, 67 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 559d88932b11..f6464e04424a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,67 +5,14 @@
# Contributor: Paul Mattal <paul@archlinux.org>
_pkgbasename=ffmpeg
-pkgname=lib32-$_pkgbasename
+pkgname=("lib32-$_pkgbasename" "lib32-lib$_pkgbasename")
pkgver=4.2.3
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc="Complete solution to record, convert and stream audio and video (32 bit)"
arch=('x86_64')
url="http://ffmpeg.org/"
license=('GPL3')
-depends=(
- "$_pkgbasename"
- 'lib32-alsa-lib'
- 'lib32-aom'
- 'lib32-bzip2'
- 'lib32-fontconfig'
- 'lib32-fribidi'
- 'lib32-glibc'
- 'lib32-gmp'
- 'lib32-gnutls'
- 'lib32-gsm'
- 'lib32-jack'
- 'lib32-lame'
- 'lib32-libass'
- 'lib32-libavc1394'
- 'lib32-libbluray'
- 'lib32-dav1d'
- 'lib32-libdrm'
- 'lib32-freetype2'
- 'lib32-libiec61883'
-# 'lib32-libmfx'
- 'lib32-libmodplug'
- 'lib32-libomxil-bellagio'
- 'lib32-libpulse'
- 'lib32-libraw1394'
-# 'lib32-libsoxr'
-# 'lib32-libssh'
- 'lib32-libtheora'
- 'lib32-libva'
- 'lib32-libvdpau'
-# 'lib32-vid.stab'
- 'lib32-libvorbis'
- 'lib32-libvpx'
- 'lib32-libwebp'
- 'lib32-libx11'
- 'lib32-x264>=0.159'
- 'lib32-x265>=3.3'
- 'lib32-libxcb'
- 'lib32-libxext'
- 'lib32-libxml2'
- 'lib32-libxv'
- 'lib32-xvidcore'
- 'lib32-opencore-amr'
- 'lib32-openjpeg2'
- 'lib32-opus'
- 'lib32-sdl2'
- 'lib32-speex'
- 'lib32-srt'
- 'lib32-v4l-utils'
- 'lib32-vmaf'
- 'lib32-xz'
- 'lib32-zlib'
-)
makedepends=(
'ffnvcodec-headers'
'git'
@@ -77,16 +24,6 @@ optdepends=(
'lib32-ladspa: LADSPA filters'
'lib32-nvidia-utils: Nvidia NVDEC/NVENC support'
)
-provides=(
- 'libavcodec.so'
- 'libavdevice.so'
- 'libavfilter.so'
- 'libavformat.so'
- 'libavutil.so'
- 'libpostproc.so'
- 'libswresample.so'
- 'libswscale.so'
-)
source=(
"git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver}"
"vmaf-model-path.patch"
@@ -172,7 +109,137 @@ build() {
make
}
-package() {
+package_lib32-libffmpeg() {
+ pkgdesc="Complete solution to record, convert and stream audio and video - library (32 bit)"
+ provides=(
+ 'libavcodec.so'
+ 'libavdevice.so'
+ 'libavfilter.so'
+ 'libavformat.so'
+ 'libavutil.so'
+ 'libpostproc.so'
+ 'libswresample.so'
+ 'libswscale.so'
+ 'lib32-ffmpeg'
+ )
+ depends=(
+ "$_pkgbasename"
+ 'lib32-alsa-lib'
+ 'lib32-aom'
+ 'lib32-bzip2'
+ 'lib32-fontconfig'
+ 'lib32-fribidi'
+ 'lib32-glibc'
+ 'lib32-gmp'
+ 'lib32-gnutls'
+ 'lib32-gsm'
+ 'lib32-jack'
+ 'lib32-lame'
+ 'lib32-libass'
+ 'lib32-libavc1394'
+ 'lib32-libbluray'
+ 'lib32-libdav1d'
+ 'lib32-libdrm'
+ 'lib32-freetype2'
+ 'lib32-libiec61883'
+# 'lib32-libmfx'
+ 'lib32-libmodplug'
+ 'lib32-libomxil-bellagio'
+ 'lib32-libpulse'
+ 'lib32-libraw1394'
+# 'lib32-libsoxr'
+# 'lib32-libssh'
+ 'lib32-libtheora'
+ 'lib32-libva'
+ 'lib32-libvdpau'
+# 'lib32-vid.stab'
+ 'lib32-libvorbis'
+ 'lib32-libvpx'
+ 'lib32-libwebp'
+ 'lib32-libx11'
+ 'lib32-x264>=0.159'
+ 'lib32-x265>=3.3'
+ 'lib32-libxcb'
+ 'lib32-libxext'
+ 'lib32-libxml2'
+ 'lib32-libxv'
+ 'lib32-xvidcore'
+ 'lib32-opencore-amr'
+ 'lib32-openjpeg2'
+ 'lib32-opus'
+ 'lib32-sdl2'
+ 'lib32-speex'
+ 'lib32-srt'
+ 'lib32-v4l-utils'
+ 'lib32-vmaf'
+ 'lib32-xz'
+ 'lib32-zlib'
+ )
+
+ cd ${_pkgbasename}
+
+ make DESTDIR="${pkgdir}" install
+
+ rm -r "${pkgdir}"/usr/{include,bin,share}
+}
+
+package_lib32-ffmpeg() {
+ pkgdesc="Complete solution to record, convert and stream audio and video (32 bit)"
+ depends=(
+ "$_pkgbasename"
+ 'lib32-alsa-lib'
+ 'lib32-aom'
+ 'lib32-bzip2'
+ 'lib32-fontconfig'
+ 'lib32-fribidi'
+ 'lib32-glibc'
+ 'lib32-gmp'
+ 'lib32-gnutls'
+ 'lib32-gsm'
+ 'lib32-jack'
+ 'lib32-lame'
+ 'lib32-libass'
+ 'lib32-libavc1394'
+ 'lib32-libbluray'
+ 'lib32-libdav1d'
+ 'lib32-libdrm'
+ 'lib32-libffmpeg'
+ 'lib32-freetype2'
+ 'lib32-libiec61883'
+# 'lib32-libmfx'
+ 'lib32-libmodplug'
+ 'lib32-libomxil-bellagio'
+ 'lib32-libpulse'
+ 'lib32-libraw1394'
+# 'lib32-libsoxr'
+# 'lib32-libssh'
+ 'lib32-libtheora'
+ 'lib32-libva'
+ 'lib32-libvdpau'
+# 'lib32-vid.stab'
+ 'lib32-libvorbis'
+ 'lib32-libvpx'
+ 'lib32-libwebp'
+ 'lib32-libx11'
+ 'lib32-x264>=0.159'
+ 'lib32-x265>=3.3'
+ 'lib32-libxcb'
+ 'lib32-libxext'
+ 'lib32-libxml2'
+ 'lib32-libxv'
+ 'lib32-xvidcore'
+ 'lib32-opencore-amr'
+ 'lib32-openjpeg2'
+ 'lib32-opus'
+ 'lib32-sdl2'
+ 'lib32-speex'
+ 'lib32-srt'
+ 'lib32-v4l-utils'
+ 'lib32-vmaf'
+ 'lib32-xz'
+ 'lib32-zlib'
+ )
+
cd ${_pkgbasename}
make DESTDIR="${pkgdir}" install
@@ -184,5 +251,5 @@ package() {
mv "$i" "$i"-32
done
- rm -r "${pkgdir}"/usr/{include,share}
+ rm -r "${pkgdir}"/usr/{include,lib32,share}
}