summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordonGR2017-04-09 18:30:00 +0300
committerGordonGR2017-04-09 18:30:00 +0300
commit5698477a9c5d0a6df1e1d42bfe95a261a3817250 (patch)
treea3140de95905a4fa5773291e87ec06453a06a195 /PKGBUILD
parentae51310f6cc3f65c6e6891da696bc3161e397ab9 (diff)
downloadaur-5698477a9c5d0a6df1e1d42bfe95a261a3817250.tar.gz
3.3.6-2: Upstream update to pl2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60c7a4a977b8..bdbdb30a7e2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=fftw
pkgname=lib32-${_pkgname}
pkgver=3.3.6
-pkgrel=1
+pkgrel=2
pkgdesc="A library for computing the discrete Fourier transform (DFT) (32 bit)"
arch=('x86_64')
license=('GPL2')
@@ -12,8 +12,8 @@ url="http://www.fftw.org/"
depends=('lib32-glibc' "${_pkgname}")
makedepends=('gcc-fortran-multilib')
options=('!libtool')
-source=("http://www.fftw.org/${_pkgname}-${pkgver}-pl1.tar.gz")
-md5sums=('682a0e78d6966ca37c7446d4ab4cc2a1')
+source=("http://www.fftw.org/${_pkgname}-${pkgver}-pl2.tar.gz")
+md5sums=('927e481edbb32575397eb3d62535a856')
# notes:
# http://www.fftw.org/fftw2_doc/fftw_6.html#SEC69
@@ -27,9 +27,9 @@ export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
-cp -a ${_pkgname}-${pkgver}-pl1 ${_pkgname}-${pkgver}-double
-cp -a ${_pkgname}-${pkgver}-pl1 ${_pkgname}-${pkgver}-long-double
-mv ${_pkgname}-${pkgver}-pl1 ${_pkgname}-${pkgver}-single
+cp -a ${_pkgname}-${pkgver}-pl2 ${_pkgname}-${pkgver}-double
+cp -a ${_pkgname}-${pkgver}-pl2 ${_pkgname}-${pkgver}-long-double
+mv ${_pkgname}-${pkgver}-pl2 ${_pkgname}-${pkgver}-single
# use upstream default CFLAGS while keeping our -march/-mtune
CFLAGS+=" -O3 -fomit-frame-pointer -malign-double -fstrict-aliasing -ffast-math"