summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNatrio2023-02-19 14:00:48 +0300
committerNatrio2023-02-19 14:00:48 +0300
commitbe993856306ba3d8631ac2985679cd87bdc3484e (patch)
tree2bd7ab0cf36faf5117affb11a1ade25a1289f992 /PKGBUILD
parent4453042368583a797fdcfd613e18b5bdb0f632c1 (diff)
downloadaur-be993856306ba3d8631ac2985679cd87bdc3484e.tar.gz
2.13.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 5 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f9709d437f52..1dd7a8556487 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,15 @@
_pkgname=freetype2
_pkgbasename=${_pkgname}-v35
pkgname=lib32-${_pkgbasename}
-pkgver=2.11.0
+pkgver=2.13.0
pkgrel=1
pkgdesc="TrueType font rendering library with v35 bytecode interpreter only"
-arch=(i686 x86_64)
+arch=(x86_64)
license=('GPL')
url="http://www.freetype.org/"
# adding harfbuzz for improved OpenType features auto-hinting
# introduces a cycle dep to harfbuzz depending on freetype wanted by upstream
-depends=('lib32-zlib' 'lib32-bzip2' 'lib32-libpng' 'lib32-harfbuzz' $_pkgbasename)
+depends=('lib32-brotli' 'lib32-zlib' 'lib32-bzip2' 'lib32-libpng' 'lib32-harfbuzz' $_pkgbasename)
makedepends=('gcc-multilib')
provides=('libfreetype.so' lib32-${_pkgname}=${pkgver})
conflicts=(lib32-${_pkgname})
@@ -23,14 +23,9 @@ source=(
0002-Enable-subpixel-rendering.patch
0003-Enable-v35-subpixel-hinting.patch
0004-Enable-long-PCF-family-names.patch
- 0006-Return_FT_Err_Ok_while_trying_to_render_bitmap.patch
- 0007-Restore_quiet_no-op_rendering_of_bitmap_glyphs.patch
- 0008-sfnt-Add-API-for-retrieving-a-COLR-v1-ClipBox-table.patch
- 0009-src-sfnt-ttcolr.c-tt_face_get_color_glyph_clipbox-Mi.patch
- 0010-sfnt-Add-missing-blend-mode-plus-to-COLR-v1.patch
)
-sha256sums=('8bee39bd3968c4804b70614a0a3ad597299ad0e824bc8aad5ce8aaf48067bde7'
- SKIP SKIP SKIP SKIP SKIP SKIP SKIP SKIP SKIP
+sha256sums=('5ee23abd047636c24b2d43c6625dcafc66661d1aca64dec9e0d05df29592624c'
+ SKIP SKIP SKIP SKIP
)
prepare() {
@@ -39,11 +34,6 @@ prepare() {
patch -Np1 -i ../0002-Enable-subpixel-rendering.patch
patch -Np1 -i ../0003-Enable-v35-subpixel-hinting.patch
patch -Np1 -i ../0004-Enable-long-PCF-family-names.patch
- patch -Np1 -i ../0006-Return_FT_Err_Ok_while_trying_to_render_bitmap.patch
- patch -Np1 -i ../0007-Restore_quiet_no-op_rendering_of_bitmap_glyphs.patch
- patch -Np1 -i ../0008-sfnt-Add-API-for-retrieving-a-COLR-v1-ClipBox-table.patch
- patch -Np1 -i ../0009-src-sfnt-ttcolr.c-tt_face_get_color_glyph_clipbox-Mi.patch
- patch -Np1 -i ../0010-sfnt-Add-missing-blend-mode-plus-to-COLR-v1.patch
}
build() {