summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBehnam Momeni2021-05-07 17:43:13 +0430
committerBehnam Momeni2021-05-07 17:43:13 +0430
commitaecb1c5df0ae0c1e37462fc753b41b4f00d09712 (patch)
treefbc05b5be48f584344f1c2ebfaa00da0c0a84388 /PKGBUILD
parent049e73e975ac63c011a9b827708671d388981544 (diff)
downloadaur-aecb1c5df0ae0c1e37462fc753b41b4f00d09712.tar.gz
Switch source to git + Use built-in options in cross-file
First change reduces the download volume in consecutive updates. Second change is required since properties section in cross-file for the c_args like settings has become deprecated.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 43db32f762e2..7f2ee86e3218 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=lib32-gegl
_pkgbase=gegl
pkgver=0.4.30
_commit=5ea11ee00d9061ca2cd61f83ece25dfcfe0e9596 # tags/GEGL_0_4_30
-pkgrel=1
+pkgrel=2
pkgdesc="Graph based image processing framework (32-bit)"
arch=('x86_64')
url="https://www.gegl.org/"
@@ -19,12 +19,12 @@ depends=("gegl=$pkgver"
'lib32-jasper'
'lib32-suitesparse' 'lib32-ffmpeg')
makedepends=('intltool' 'ruby' 'mesa' 'glu' 'exiv2' 'vala' 'gobject-introspection' 'meson' 'python-gobject')
-source=("https://gitlab.gnome.org/GNOME/$_pkgbase/-/archive/$_commit/$_pkgbase-$_commit.tar.gz"
+source=("git+https://gitlab.gnome.org/GNOME/$_pkgbase.git#commit=$_commit"
"x86-linux-gnu"
"gegl-openexr3.patch"
"pkgconf32")
-sha512sums=('0fb5325208fc07bf802fab5d32488ad3e0447a71a9c7447687ad37d479f52924167d49ee579ede48599bdede9644322e25178f620cc0a8f5dad9f51c75907121'
- 'c90a2e8d8753d4474afbaa5f1def579b4fe9580904b25125e2f942fa722a6ed54340e467d2ddf60ab9d3aeeeb93f5f740502cafe9a1f52d55da3bd78baa3b5c5'
+sha512sums=('SKIP'
+ '3760e32b315d45494a7e1480a5b56f64d6fcf3eb99376bee21f499e9ea5b3e06a111d773a4223d258035fa8d89a94b4e19fbe9be92478084fef8d195d0f3a484'
'bc732c99026afd59aaa70bd98622bdedb2173ac3242d4648f6222bc966e60b9f9b2df7360fee3cbdb7240f6758d7382d6986d02a133b203c1e47af3782b7f475'
'f704e11f3054312e35974194af845e00fdc795aa97e82d425fb52ff8e628702926551b583f0354f9f9e7eafeb71c7f348c288457ff19a8c4807c58f637d0d946')
@@ -33,13 +33,13 @@ prepare() {
"/usr/lib/pkgconfig/gobject-introspection-1.0.pc" \
"/usr/lib/pkgconfig/pygobject-3.0.pc" \
"$srcdir/"
- cd "$srcdir/$_pkgbase-$_commit"
+ cd "$srcdir/$_pkgbase"
patch -p1 < ../gegl-openexr3.patch
}
build() {
mkdir -p "build"
- arch-meson "${_pkgbase}-$_commit" "build" -Dworkshop=true -Dmrg=disabled -Dmaxflow=disabled --cross-file x86-linux-gnu --libdir=/usr/lib32
+ arch-meson "${_pkgbase}" "build" -Dworkshop=true -Dmrg=disabled -Dmaxflow=disabled --cross-file x86-linux-gnu --libdir=/usr/lib32
ninja -C "build"
}