summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBehnam Momeni2023-07-13 16:53:21 +0330
committerBehnam Momeni2023-07-13 17:22:03 +0330
commitcf80482b70e111f9fa8454d64e923eebde628792 (patch)
treeea639a8436532b1f7c5023370b684ae0395aac14 /PKGBUILD
parent36c0c7fc6c620995c30d22f39b182620412dee32 (diff)
downloadaur-cf80482b70e111f9fa8454d64e923eebde628792.tar.gz
Drop openjpeg2, libraw, and documentation building dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e1e97a4a5f9..6bd165cd67be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=lib32-gegl
_pkgbase=gegl
pkgver=0.4.46
_commit=e6cb97763e422d8853fc95c665f8b0c73f025dd8 # tags/GEGL_0_4_46
-pkgrel=1
+pkgrel=2
pkgdesc="Graph based image processing framework (32-bit)"
arch=('x86_64')
url="https://www.gegl.org/"
@@ -13,24 +13,19 @@ license=('GPL3' 'LGPL3')
depends=("gegl>=$pkgver"
'lib32-babl' 'lib32-libspiro' 'lib32-json-glib'
'lib32-poppler-glib'
- 'lib32-libgexiv2' 'lib32-libraw>=0.21.0' 'lib32-openexr'
+ 'lib32-libgexiv2' 'lib32-openexr'
'lib32-librsvg' 'lib32-libtiff'
'lib32-lensfun' 'lib32-luajit'
- 'lib32-openjpeg2'
'lib32-suitesparse'
'lib32-ffmpeg' 'ffmpeg')
-makedepends=('intltool' 'ruby' 'mesa' 'glu' 'exiv2' 'meson' 'vala'
- 'xorgproto' 'shared-mime-info' 'lib32-gobject-introspection'
- 'lib32-sdl2' 'python-gobject')
+makedepends=('intltool' 'ruby' 'mesa' 'glu' 'exiv2' 'meson'
+ 'xorgproto' 'shared-mime-info' 'lib32-sdl2')
source=("git+https://gitlab.gnome.org/GNOME/$_pkgbase.git#commit=$_commit"
"x86-linux-gnu")
sha512sums=('SKIP'
'97c193bdf744a8853b4463dd9f995faea0e8b269b1b7ef3b9ffcf10c173aa44a0e6edcda5cb69be71af8a4a649332cb841ac5849ea8256f0cfeb5a3cedea251c')
prepare() {
- for pkg in vapigen.pc pygobject-3.0.pc; do
- cp "/usr/lib/pkgconfig/$pkg" "$srcdir/"
- done
for pkg in xproto.pc kbproto.pc xextproto.pc renderproto.pc shared-mime-info.pc; do
cp "/usr/share/pkgconfig/$pkg" "$srcdir/"
done
@@ -51,6 +46,7 @@ build() {
--wrap-mode nodownload \
-Db_lto=true -Db_pie=true \
-Dworkshop=true -Dmrg=disabled -Dmaxflow=disabled \
+ -Dlibraw=disabled -Ddocs=false -Dintrospection=false \
-Djasper=disabled \
--cross-file x86-linux-gnu
ninja -C "build"