summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukas Sabota2022-03-07 13:43:09 -0500
committerLukas Sabota2022-03-07 13:43:09 -0500
commit49ed904c1835d2b9f08b901b834ab358e76e8960 (patch)
tree059719be837f2b48869d487dc044295654618a5a /PKGBUILD
parentb96eda423fe76fd69b5f0677076d230eeaf93527 (diff)
downloadaur-lib32-glib.tar.gz
fix compilation errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0bdceb58f60c..232c7b24ca8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=glib
pkgname=lib32-glib
pkgver=1.2.10
-pkgrel=4
+pkgrel=5
pkgdesc="Common C routines used by Gtk+ and other libs (32-bit)"
arch=('x86_64')
url="http://www.gtk.org/"
@@ -12,7 +12,6 @@ license=('LGPL')
depends=('lib32-glibc' 'sh')
makedepends=('gcc-multilib')
options=('!makeflags')
-install=glib.install
source=(https://download.gnome.org/sources/glib/1.2/${_pkgname}-${pkgver}.tar.gz
glib-1.2.10-gcc9.patch
gcc340.patch aclocal-fixes.patch glib1-autotools.patch)
@@ -32,6 +31,8 @@ prepare() {
}
build() {
+ export CFLAGS="${CFLAGS} -Wno-error -Wno-format -Wno-format-security"
+ export CXXFLAGS="${CXXFLAGS} -Wno-error -Wno-format -Wno-format-security"
export CC="gcc -m32"
cd ${_pkgname}-${pkgver}
if [[ $CARCH = "i686" ]]; then