summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIru Cai2016-03-07 21:36:52 +0800
committerIru Cai2016-03-07 21:36:52 +0800
commitc5431051b4ffa05c4e76d8392a41d8fa556c1e75 (patch)
tree877f99f53e19ec9b04b5d89c312cc4e9e977472e /PKGBUILD
downloadaur-c5431051b4ffa05c4e76d8392a41d8fa556c1e75.tar.gz
lib32-gnu-efi-libs: initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e942720614b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Keshav Amburay <(the ddoott ridikulus ddoott rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
+# Contributor: Alessio 'mOLOk' Bolognino <themolok@gmail.com>
+
+_EFI_ARCH="ia32"
+
+_pkgver="3.0.3"
+pkgname="lib32-gnu-efi-libs"
+pkgver="${_pkgver}"
+pkgrel="1"
+pkgdesc="Library for building UEFI Applications using GNU toolchain"
+url="http://sourceforge.net/projects/gnu-efi/"
+license=('GPL')
+arch=('x86_64')
+options=('!strip' '!makeflags' '!buildflags')
+makedepends=('pciutils')
+source=("http://download.sourceforge.net/gnu-efi/gnu-efi-${pkgver}.tar.bz2")
+md5sums=('15a4bcbc18a9a5e8110ed955970622e6')
+
+# override the CFLAGS to build a libefi compatible with i586
+_CFLAGS="-march=i586 -mtune=i586 -fno-stack-protector"
+
+build() {
+ cd "${srcdir}/gnu-efi-${_pkgver}/"
+
+ CFLAGS="${_CFLAGS}" make ARCH=ia32 lib gnuefi inc apps
+}
+
+package() {
+ cd "${srcdir}/gnu-efi-${_pkgver}/"
+
+ CFLAGS="${_CFLAGS}" make ARCH=ia32 INSTALLROOT="${pkgdir}" PREFIX="/usr" LIBDIR="/usr/lib32" install
+ rm -rf "${pkgdir}/usr/include/efi"/{*.h,protocol}
+
+ install -d "${pkgdir}/usr/share/gnu-efi/apps/${_EFI_ARCH}/"
+ install -D -m0644 "${srcdir}/gnu-efi-${_pkgver}/${_EFI_ARCH}/apps"/*.efi "${pkgdir}/usr/share/gnu-efi/apps/${_EFI_ARCH}/"
+}