summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkuma2023-02-14 00:11:27 +0800
committerkuma2023-02-14 00:11:27 +0800
commit6521ead508bc2e7cfbf1cdf761964e9577212f2e (patch)
tree30afc2acc6c3f4f8afe43c0424397b2f7ba08ffe /PKGBUILD
parent706b0d7b100c7024d958cc9b6e8dea2524d3129d (diff)
downloadaur-6521ead508bc2e7cfbf1cdf761964e9577212f2e.tar.gz
fix: disable lib32-svt-av1 support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59f73bc8bea2..d61c32a2a9a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ pkgname=(
lib32-gstreamer-vaapi-git
)
-pkgver=1.22.0+r153+g9a300fc501
+pkgver=1.22.0+r419+gaeb262a7e1
pkgrel=1
pkgdesc="Multimedia graph framework (32-bit)"
url="https://gstreamer.freedesktop.org/"
@@ -138,6 +138,7 @@ build() {
-D gst-plugins-bad:openmpt=disabled # due to no lib32-openmpt support
-D gst-plugins-bad:qroverlay=disabled # due to no lib32-qrencode support
-D gst-plugins-bad:svthevcenc=disabled # due to no lib32-svthevcenc support
+ -D gst-plugins-bad:svtav1=disabled # due to no lib32-svt-av1
-D gst-plugins-bad:wpe=disabled # due to no lib32-wpe support
-D gst-plugins-bad:zxing=disabled # due to no lib32-zxing support
-D gst-plugins-bad:amfcodec=disabled # only support windows
@@ -165,14 +166,14 @@ build() {
meson compile -C build
}
-# check() (
-# mkdir -p -m 700 "${XDG_RUNTIME_DIR:=$PWD/runtime-dir}"
-# export XDG_RUNTIME_DIR
+check() (
+ mkdir -p -m 700 "${XDG_RUNTIME_DIR:=$PWD/runtime-dir}"
+ export XDG_RUNTIME_DIR
-# # Flaky due to timeouts
-# xvfb-run -s '-nolisten local' \
-# meson test -C build --print-errorlogs || :
-# )
+ # Flaky due to timeouts
+ xvfb-run -s '-nolisten local' \
+ meson test -C build --print-errorlogs || :
+)
_install() {
local src dir