summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordonGR2015-06-28 15:44:30 +0300
committerGordonGR2015-06-28 15:44:30 +0300
commit5067205f3e107de6c9fe299b3520e82e985e9613 (patch)
tree9d108d1e28c09c7bd409cb955ceb88da146be4f6 /PKGBUILD
parente5e2ed3221b0e03b1017789eb8534be8f01c30de (diff)
downloadaur-5067205f3e107de6c9fe299b3520e82e985e9613.tar.gz
On par with gstreamer0.10-bad 0.10.23-10 from [extra]
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 30 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ecef365b2673..9dbb525e07ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgbase=gstreamer0.10-bad
pkgbase=lib32-$_pkgbase
pkgname=('lib32-gstreamer0.10-bad' 'lib32-gstreamer0.10-bad-plugins')
pkgver=0.10.23
-pkgrel=6
+pkgrel=7
arch=('x86_64')
license=('LGPL' 'GPL')
pkgdesc="GStreamer Multimedia Framework Bad Plugin libraries (gst-plugins-bad) (32 bit)"
@@ -14,17 +14,39 @@ makedepends=('gcc-multilib' 'lib32-libvdpau' 'lib32-libass' 'lib32-libcdaudio' '
url="http://gstreamer.freedesktop.org/"
options=(!libtool !emptydirs)
-source=($url/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz)
-md5sums=('e4822fa2cc933768e2998311a1565979')
+source=("git://anongit.freedesktop.org/gstreamer-sdk/gst-plugins-bad#commit=57569a4854a0f2d14ef19a8264a4ae9a7a1d1125"
+fix-libmodplug-include.patch
+drop-vpx-compat-defs.patch
+disable-assrender-test.patch
+disable-camerabin-test.patch
+faad2-version-check.patch)
+
+md5sums=('SKIP'
+ '447c12a784b13aac9e47e48741d26a67'
+ '476a02484af2e9bdc1cb4a703b531cec'
+ '025438e630b571bfa90171e36d4240e5'
+ '2e17f524b0db1469cfa36703bf459153'
+ 'dfa7e5723542d0fabebf509cb321535b')
+
+prepare() {
+cd gst-plugins-bad
+sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' -i configure.ac
+patch -Np1 -i ../fix-libmodplug-include.patch
+patch -Np1 -i ../drop-vpx-compat-defs.patch
+patch -Np1 -i ../disable-assrender-test.patch
+patch -Np1 -i ../disable-camerabin-test.patch
+patch -Np1 -i ../faad2-version-check.patch
+}
build() {
export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
-
-cd gst-plugins-bad-$pkgver
+
+cd gst-plugins-bad
+NOCONFIGURE=1 ./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --disable-static --enable-experimental \
+ --disable-static --enable-experimental --disable-gtk-doc \
--with-package-name="GStreamer Bad Plugins (Archlinux)" \
--with-package-origin="http://www.archlinux.org/" \
--libdir=/usr/lib32 \
@@ -39,7 +61,7 @@ package_lib32-gstreamer0.10-bad() {
pkgdesc="GStreamer Multimedia Framework Bad Plugin libraries (gst-plugins-bad, lib32)"
depends=('lib32-gstreamer0.10-base')
-cd gst-plugins-bad-$pkgver
+cd gst-plugins-bad
make DESTDIR="$pkgdir" install
rm -rf "$pkgdir/usr"/{include,share}
}
@@ -50,7 +72,7 @@ depends=("lib32-gstreamer0.10-bad=${pkgver}" 'lib32-libdca' 'bzip2' 'lib32-libdc
install=lib32-gstreamer0.10-bad-plugins.install
-cd gst-plugins-bad-$pkgver
+cd gst-plugins-bad
make -C gst-libs DESTDIR="${pkgdir}" install
make -C ext DESTDIR="${pkgdir}" install
make -C sys DESTDIR="${pkgdir}" install