summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRodrigo Bezerra2023-07-16 13:14:13 -0300
committerRodrigo Bezerra2023-07-16 13:14:13 -0300
commit34bf2f5c74bb401a9872cfc0c7ab4d90d347ab80 (patch)
tree28f1c62bea80bf9185b55cd85611041e50b35752 /PKGBUILD
parent1154cc8fc83934fc6b6a5ce85fa6414c00a0747d (diff)
downloadaur-34bf2f5c74bb401a9872cfc0c7ab4d90d347ab80.tar.gz
Update to version 1.6.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 24 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37208865e294..0b1d1ded28a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,25 @@
# Maintainer: Rodrigo Bezerra <rodrigobezerra21 at gmail dot com>
-pkgname=lib32-gupnp
-pkgver=1.6.3
+pkgname=(
+ lib32-gupnp
+)
+pkgver=1.6.4
pkgrel=1
pkgdesc="An object-oriented UPNP framework (32-bit)"
arch=(x86_64)
url="https://wiki.gnome.org/Projects/GUPnP"
license=(LGPL)
-depends=(lib32-gssdp gupnp)
-makedepends=(git gobject-introspection meson vala)
-_commit=adb51197a7e3120027a295b36beda4571e628758 # tags/gupnp-1.6.3^0
+depends=(
+ lib32-gssdp
+ gupnp
+)
+makedepends=(
+ git
+ gobject-introspection
+ meson
+ vala
+)
+_commit=b6a70d48f7835fc7e91c1afbf0a761fabcaf8df9 # tags/gupnp-1.6.4^0
source=("git+https://gitlab.gnome.org/GNOME/gupnp.git#commit=$_commit")
sha256sums=('SKIP')
@@ -21,21 +31,22 @@ pkgver() {
prepare() {
cd gupnp
-
- # Unbreak man page build
- git revert -n 8795626a07963a91400773cfe04d4f2f1c37ff14
}
build() {
- export CC='gcc -m32'
- export CXX='g++ -m32'
- export PKG_CONFIG='/usr/bin/i686-pc-linux-gnu-pkg-config'
-
- arch-meson gupnp build \
+ local meson_options=(
--libdir='/usr/lib32' \
-Dgtk_doc=false \
-Dintrospection=false \
-Dexamples=false
+ )
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG='/usr/bin/i686-pc-linux-gnu-pkg-config'
+
+ arch-meson gupnp build "${meson_options[@]}"
+
meson compile -C build
}