summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2020-05-23 11:16:16 -0400
committerVincent Grande2020-05-23 11:16:16 -0400
commit674b73f886feb51335948cb0d84a3dbddb5cae50 (patch)
tree1e813dbfa5aa08eb479c8f86c3cb5a812a17d2dc /PKGBUILD
parent1b637422e7a29060397bb808557298c0d7a48a84 (diff)
downloadaur-674b73f886feb51335948cb0d84a3dbddb5cae50.tar.gz
dependency update
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 535bd25d347d..19eebf70b19f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,8 @@ pkgdesc="OpenType text shaping engine (32-bit)"
url="http://www.freedesktop.org/wiki/Software/HarfBuzz"
arch=(x86_64)
license=(MIT)
-depends=(lib32-glib2 lib32-freetype2 harfbuzz)
-makedepends=(lib32-cairo lib32-icu gcc-multilib ragel git python gobject-introspection)
-checkdepends=(python-fonttools python-setuptools)
+makedepends=(lib32-glib2 lib32-freetype2 lib32-cairo lib32-icu gcc-multilib ragel git python harfbuzz gobject-introspection)
+#checkdepends=(python-fonttools python-setuptools)
source=("git+https://github.com/harfbuzz/harfbuzz")
sha256sums=('SKIP')
@@ -50,9 +49,9 @@ build() {
#}
package_lib32-harfbuzz-git() {
-
+ depends=(lib32-glib2 lib32-freetype2 libglib-2.0.so libfreetype.so libgobject-2.0.so harfbuzz)
provides=(lib32-harfbuzz libharfbuzz.so libharfbuzz-subset.so libharfbuzz-gobject.so)
- conflicts=(lib32-harfbuzz libharfbuzz.so libharfbuzz-subset.so libharfbuzz-gobject.so)
+ conflicts=(lib32-harfbuzz)
cd harfbuzz
make DESTDIR="$pkgdir" install
@@ -69,9 +68,9 @@ package_lib32-harfbuzz-git() {
package_lib32-harfbuzz-icu-git() {
pkgdesc="OpenType text shaping engine (32-bit, ICU integration)"
- depends=(lib32-harfbuzz lib32-icu harfbuzz-icu)
+ depends=(lib32-harfbuzz lib32-icu harfbuzz-icu libharfbuzz.so)
provides=(lib32-harfbuzz-icu libharfbuzz-icu.so)
- conflicts=(lib32-harfbuzz-icu libharfbuzz-icu.so)
+ conflicts=(lib32-harfbuzz-icu)
mv hb-icu/* "$pkgdir"