summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Demers2015-07-24 00:26:41 -0400
committerAlexandre Demers2015-07-24 00:26:41 -0400
commit31174aa694bc74b2b4b190dffa54c65b720121a4 (patch)
tree689fbf0d9593d36c25fbc3522eb22daf709cad6e /PKGBUILD
parent7cec3c1b6b375b13bb03a35f2303153ea5500734 (diff)
downloadaur-lib32-ibus-qt.tar.gz
Accelerate build by using more cores
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b752089935c7..e624eb5e4d5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgbasename=ibus-qt
pkgname=lib32-${_pkgbasename}
pkgver=1.3.3
-pkgrel=1
+pkgrel=2
pkgdesc='IBus qt library and IBus qt input method plugin'
arch=('x86_64')
license=('LGPL')
@@ -15,6 +15,9 @@ source=("https://github.com/ibus/ibus-qt/releases/download/${pkgver}/${_pkgbasen
sha1sums=('3711d9099ac97d1b3bc7313080a016caa04ae66e')
build() {
+ _cpucount=$(grep -c processor /proc/cpuinfo 2>/dev/null)
+ _jc=$((${_cpucount:-1}))
+
cd "${srcdir}"
mkdir -p build
cd build
@@ -24,7 +27,7 @@ build() {
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
cmake "../${_pkgbasename}-${pkgver}-Source" -DCMAKE_INSTALL_PREFIX=/usr -DLIBDIR=lib32 -DQT_PLUGINS_DIR=/usr/lib32/qt/plugins/
- make
+ make -j $_jc
}
package() {