summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authororumin2018-01-04 04:37:44 +0900
committerorumin2018-01-04 04:37:44 +0900
commit27d3ba20b8d3ea2004808b876e6cb055f03d988e (patch)
tree150c87e85aeeffe25fcea89448fe8b87c1715620 /PKGBUILD
parent888156955118456364c33a1194643e800ec125b5 (diff)
downloadaur-27d3ba20b8d3ea2004808b876e6cb055f03d988e.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD79
1 files changed, 48 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0791ae9c85c3..731913743e45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=lib32-imagemagick
_basename=imagemagick
-pkgver=6.9.9.18
+pkgver=7.0.7.19
pkgrel=1
pkgdesc="An image viewing/manipulation program (32-bit)"
arch=('x86_64')
@@ -14,55 +14,72 @@ makedepends=('lib32-libltdl' 'lib32-lcms2' 'lib32-libxt' 'lib32-fontconfig'
'lib32-libxext' 'ghostscript' 'lib32-openexr' 'lib32-libwmf'
'lib32-librsvg' 'lib32-libxml2' 'lib32-liblqr' 'lib32-openjpeg2' 'lib32-libraw'
'opencl-headers' 'lib32-ocl-icd' 'lib32-libwebp' 'subversion' 'lib32-glu' 'git' 'imagemagick')
-optdepends=('imagemagick-doc: for additional information'
- 'ghostscript: for Ghostscript support'
- 'openexr: for OpenEXR support'
- 'openjpeg2: for JP2 support'
- 'libwmf: for WMF support'
- 'librsvg: for SVG support'
- 'libxml2: for XML support'
- 'libpng: for PNG support'
- 'libwebp: for WEBP support')
-options=('!docs' 'libtool' '!emptydirs')
+checkdepends=(gsfonts ttf-dejavu)
+_tarname=ImageMagick-${pkgver%.*}-${pkgver##*.}
+options=('!docs' 'libtool' '!emptydirs' libtool)
-source=(http://www.imagemagick.org/download/releases/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc}
- perlmagick.rpath.patch)
-sha1sums=('402c64151d1c38d59901a7229aaaf69a5e3a7c3f'
- 'SKIP'
- 'e143cf9d530fabf3b58023899b5cc544ba93daec')
-validpgpkeys=('D8272EF51DA223E4D05B466989AB63D48277377A')
+source=(http://www.imagemagick.org/download/$_tarname.tar.xz{,.asc}
+ arch-fonts.diff)
+sha256sums=('5f1156824c37e5dde6ec37c5b1c51d9806f6d0e97aeaeb1e6907d7aba15951d9'
+ 'SKIP'
+ 'a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73')
+validpgpkeys=('D8272EF51DA223E4D05B466989AB63D48277377A') # Lexie Parsimoniae
+
+shopt -s extglob
prepare() {
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
- sed '/AC_PATH_XTRA/d' -i configure.ac
- autoreconf --force --install
- patch -p0 -i "${srcdir}/perlmagick.rpath.patch"
+ cd $_tarname
+
+ # Fix up typemaps to match our packages, where possible
+ patch -Np1 -i "${srcdir}/arch-fonts.diff"
+
}
build() {
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
+ cd $_tarname
export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- ./configure --prefix=/usr --sysconfdir=/etc --with-modules \
+ ./configure --prefix=/usr --sysconfdir=/etc \
--build=i686-pc-linux-gnu --libdir=/usr/lib32 \
- --enable-hdri --with-wmf --with-openexr --with-xml \
- --with-webp --with-gslib --with-gs-font-dir=/usr/share/fonts/Type1 \
- --with-lqr --with-rsvg --enable-opencl --with-openjp2 --without-gvc \
- --without-djvu --without-autotrace \
- --without-jbig --without-fpx --without-dps --without-fftw
+ --with-dejavu-font-dir=/usr/share/fotns/TTF \
+ --with-gs-font-dir=/usr/share/fotns/gsfonts \
+ PSDelegate=/usr/bin/gs \
+ XPSDelegate=/usr/bin/gxps \
+ PCLDelegate=/usr/bin/gpcl6 \
+ --enable-hdri \
+ --enable-opencl \
+ --with-gslib \
+ --with-lqr \
+ --with-modules \
+ --with-openexr \
+ --with-openjp2 \
+ --with-rsvg \
+ --with-webp \
+ --with-wmf \
+ --with-xml \
+ --without-autotrace \
+ --without-djvu \
+ --without-dps \
+ --without-fftw \
+ --without-fpx \
+ --without-gcc-arch \
+ --without-gvc \
+ --without-jbig
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
check() {
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
-# make check
+ cd $_tarname
+ ulimit -n 4096
+ make check
}
package() {
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
+ cd $_tarname
make -j1 DESTDIR="${pkgdir}" install
#Cleaning