summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabian Maurer2019-03-20 20:47:09 +0100
committerFabian Maurer2019-04-10 16:56:59 +0200
commit7227c54312adefc862f66ed3dc4de5882c6a9e62 (patch)
tree56ace6ef2699d2034dc959d96a6037c9e9a6d6c9 /PKGBUILD
parentd0f243ae5b7a6fce0d0419e5666f78ca896652c6 (diff)
downloadaur-7227c54312adefc862f66ed3dc4de5882c6a9e62.tar.gz
Adopt and update to 1.5.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f851fb543202..0dc86c04f449 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,19 @@
-# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+# Maintainer: Fabian Maurer <dark.shadow4@web.de>
+# Contributor: Rafael Fontenelle <rafaelff@gnome.org>
_name=ldb
pkgname=lib32-$_name
-pkgver=1.4.3
+pkgver=1.5.4
pkgrel=1
pkgdesc="A schema-less, ldap like, API and database"
arch=('x86_64')
url="https://ldb.samba.org/"
license=('GPL3')
depends=('lib32-talloc' 'lib32-tevent' 'lib32-tdb' 'lib32-popt' 'lib32-libbsd' 'ldb')
-makedepends=('lib32-python2' 'lib32-cmocka')
-optdepends=('lib32-python2: for python bindings')
+makedepends=('lib32-python3' 'lib32-cmocka')
+optdepends=('lib32-python3: for python bindings')
source=(https://samba.org/ftp/${_name}/${_name}-${pkgver}.tar.gz)
-md5sums=('00888f4113ce8e44ba01638e6b2729fc')
-
-prepare() {
- cd ${_name}-${pkgver}
- sed -i -e "s|/usr/bin/env python$|/usr/bin/env python2|" buildtools/bin/waf
-}
+md5sums=('24d9f18b085ba27f96d4dec643abea39')
build() {
cd ${_name}-${pkgver}
@@ -25,8 +21,9 @@ build() {
export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- export PYTHON='/usr/bin/python2-32'
- export PYTHON_CONFIG='/usr/bin/python2-32-config'
+ export PYTHON='/usr/bin/python3-32'
+ export PYTHON_CONFIG='/usr/bin/python3-32-config'
+ export PYTHONPATH="/usr/lib32/python3.7/site-packages"
./configure --prefix=/usr \
--disable-rpath \