summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordonGR2015-06-08 14:05:01 +0300
committerGordonGR2015-06-08 14:05:01 +0300
commitea655903244463c36a17e024cce01907ee38ea45 (patch)
treefdd8a33bd979303b8d0a3ac2a00e075c664e03ab /PKGBUILD
downloadaur-ea655903244463c36a17e024cce01907ee38ea45.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e28011b3e5cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: GordonGR <ntheo1979@gmail.com>
+# Contributor: josephgbr <rafael.f.f1@gmail.com>
+
+_pkgname=libdvdcss
+pkgname=lib32-${_pkgname}
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Portable abstraction library for DVD decryption (32 bit)"
+url="http://www.videolan.org/libdvdcss"
+arch=('x86_64')
+license=('GPL')
+depends=('lib32-glibc' "${_pkgname}")
+makedepends=('gcc-multilib')
+options=('!docs' '!emptydirs')
+source=(http://download.videolan.org/pub/${_pkgname}/${pkgver}/${_pkgname}-${pkgver}.tar.bz2)
+md5sums=('7f0fdb3ff91d638f5e45ed7536f7eb67')
+
+build() {
+export CC='gcc -m32'
+export CXX='g++ -m32'
+export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+cd "${_pkgname}-${pkgver}"
+./configure --prefix=/usr --libdir=/usr/lib32
+make
+}
+
+package() {
+cd "${_pkgname}-${pkgver}"
+make DESTDIR="${pkgdir}" install
+rm -rf "${pkgdir}/usr/include"
+}