summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2018-04-03 12:09:17 -0400
committerAndrew Sun2018-04-03 12:09:17 -0400
commita33b93bf1539af38d84f8de29607b764f575d5db (patch)
treed2ea770006ca0013a2b78b91b8d4a57a3c884608 /PKGBUILD
downloadaur-a33b93bf1539af38d84f8de29607b764f575d5db.tar.gz
add lib32-libexosip2 (version 5.0.0)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85c013ccd993
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+
+pkgname=lib32-libexosip2
+pkgver=5.0.0
+pkgrel=1
+pkgdesc="A library that hides the complexity of using SIP for multimedia session establishement"
+arch=('x86_64')
+url="https://savannah.nongnu.org/projects/exosip/"
+license=('GPL')
+depends=('lib32-glibc' 'lib32-gcc-libs' 'lib32-libosip2>=4.0.0' 'lib32-openssl')
+validpgpkeys=('34C3985D068879312FE23C8BB5902A3AD90A5421')
+source=(https://download.savannah.gnu.org/releases/exosip/libexosip2-${pkgver}.tar.gz
+ openssl110.patch)
+sha256sums=('a26558594de95405d3adeee554a7c10cb3ec5a9316a879e679b53a99a9cf2e1f'
+ 'e60ef8fe99e7aa8641398a70708ab1e4f85d04872f1c658949afc4fd657c4d5a')
+
+prepare() {
+ cd "${srcdir}/libexosip2-${pkgver}"
+ patch -Np1 -i "${srcdir}/openssl110.patch"
+}
+
+build() {
+ cd "${srcdir}/libexosip2-${pkgver}"
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure --prefix=/usr --libdir=/usr/lib32
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd "${srcdir}/libexosip2-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/{bin,include,share}
+}