summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRodrigo Bezerra2023-10-02 07:18:59 -0300
committerRodrigo Bezerra2023-10-02 07:18:59 -0300
commit830c959e195bb0c7fc693a2f39c4d93d33074aea (patch)
treeaa3ef6f486cbeb296434d2e38373cf79a9a637e7 /PKGBUILD
parent4af47bb4a5486ab9eae1bdfaf83657a212b92666 (diff)
downloadaur-830c959e195bb0c7fc693a2f39c4d93d33074aea.tar.gz
Update to version 2.5.31
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 916b54902033..437fa09fe083 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_basename=libgphoto2
pkgname=lib32-libgphoto2
-pkgver=2.5.30
+pkgver=2.5.31
pkgrel=1
pkgdesc="Digital camera access library (32-bit)"
url="http://www.gphoto.org/"
@@ -11,7 +11,7 @@ arch=(x86_64)
license=(LGPL)
depends=(curl lib32-libexif lib32-gd lib32-libltdl lib32-libusb lib32-libxml2 libgphoto2)
makedepends=(autoconf-archive git)
-_commit=6511898c4be52a9306f0791476561bdcebf5317d # tags/libgphoto2-2_5_30-release
+_commit=ba28af2d22fd4cb7fa76a8ff569ba498e8021db5 # tags/libgphoto2-2_5_31-release
source=("git+https://github.com/gphoto/libgphoto2#commit=$_commit")
sha256sums=('SKIP')
validpgpkeys=('7C4AFD61D8AAE7570796A5172209D6902F969C95') # Marcus Meissner
@@ -29,19 +29,24 @@ prepare() {
}
build() {
- cd $_basename
-
export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- ./configure \
- --build=i686-pc-linux-gnu \
- --prefix=/usr \
- --libdir=/usr/lib32 \
+ local configure_options=(
+ --build=i686-pc-linux-gnu
+ --prefix=/usr
+ --libdir=/usr/lib32
+ --sysconfdir=/etc
+ --localstatedir=/var
--disable-rpath
+ )
+
+ cd $_basename
+
+ ./configure "${configure_options[@]}"
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}