summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordonGR2015-07-23 16:08:05 +0300
committerGordonGR2015-07-23 16:08:05 +0300
commit80778b18653d154792d8e801d69e124506afbbcd (patch)
treea44b65e6d490b3510d59a799be3e0fb79ee81150 /PKGBUILD
downloadaur-80778b18653d154792d8e801d69e124506afbbcd.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a80a9d0597c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: GordonGR <ntheo1979@gmail.com>
+# Maintainer: josephgbr <rafael.f.f1@gmail.com>
+
+_pkgname=liblrdf
+pkgname=lib32-${_pkgname}
+pkgver=0.5.0
+pkgrel=3
+pkgdesc="A library for the manipulation of RDF file in LADSPA plugins (32 bit)"
+arch=('x86_64')
+url="https://github.com/swh/LRDF"
+depends=('lib32-raptor' "$_pkgname")
+makedepends=('gcc-multilib')
+license=('GPL')
+source=(${_pkgname}-${pkgver}.tar.gz::https://github.com/swh/LRDF/tarball/${pkgver})
+md5sums=('005ea24152620da7f2ee80a78e17f784')
+
+build() {
+export CC='gcc -m32'
+export CXX='g++ -m32'
+export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+cd swh-LRDF-7ebc032
+sed -i 's#AM_CONFIG_HEADER(config.h)#AC_CONFIG_HEADERS([config.h])#' configure.ac
+
+autoreconf -vfi
+./configure --prefix=/usr --libdir=/usr/lib32
+make
+}
+
+package() {
+cd swh-LRDF-7ebc032
+make DESTDIR="${pkgdir}" install
+rm -rf "${pkgdir}"/usr/{include,share}
+}