summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRodrigo Bezerra2019-03-18 22:46:51 -0300
committerRodrigo Bezerra2019-03-18 22:46:51 -0300
commitbed4436d1230203abec7f4346904c19e322dad8c (patch)
treed9e74039cc9fbdfc0def8e3d923a8eecdd82e53c /PKGBUILD
parent3493f694a09107601bd5c959d1f246745dc19103 (diff)
downloadaur-bed4436d1230203abec7f4346904c19e322dad8c.tar.gz
Updates to the PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2ed06ea0e9e8..72788a3970da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_basename=libnice
pkgname=lib32-libnice
pkgver=0.1.15
-pkgrel=1
+pkgrel=2
pkgdesc="An implementation of the IETF's draft ICE (for p2p UDP data streams) (32-bit)"
url="https://nice.freedesktop.org"
arch=(x86_64)
@@ -11,7 +11,7 @@ license=(LGPL)
depends=(lib32-gstreamer lib32-gupnp-igd libnice)
makedepends=(git gobject-introspection meson)
_commit=e25c3e5113c7b7002a78bcca2ecf058bbf7de6d4 # tags/0.1.15^0
-source=("git+https://anongit.freedesktop.org/git/libnice/libnice#commit=$_commit")
+source=("git+https://gitlab.freedesktop.org/libnice/libnice.git#commit=$_commit")
sha256sums=('SKIP')
pkgver() {
@@ -27,14 +27,18 @@ build() {
arch-meson libnice build \
--libdir='/usr/lib32' \
- -Dtests=disabled \
- -Dgtk_doc=disabled
+ -Dgtk_doc=disabled \
+ -Dtests=disabled
ninja -C build
}
+check() {
+ meson test -C build --print-errorlogs
+}
+
package() {
- DESTDIR="${pkgdir}" ninja -C build install
+ DESTDIR="${pkgdir}" meson install -C build
rm -rf "${pkgdir}"/usr/{bin,include,share}
}