summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2016-12-15 15:50:20 -0800
committerLlewelyn Trahaearn2016-12-15 15:50:20 -0800
commit45bf31b8a292e03f5d0e5dcf9bc570aa343e6db2 (patch)
tree4ba391ff503cfb57d5bfd9788365dfb02cb6c147 /PKGBUILD
parentfa225fec1de52df808ac41e62f65a00061ca9f78 (diff)
downloadaur-45bf31b8a292e03f5d0e5dcf9bc570aa343e6db2.tar.gz
Update to v0.7.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 94fded6ee5df..5c2f3051d658 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,15 @@
# Contributor: Jan de Groot <jgc at archlinux dot org>
pkgname=lib32-libnotify
-pkgver=0.7.6
-pkgrel=6
+pkgver=0.7.7
+pkgrel=1
pkgdesc="Library for sending desktop notifications (32-bit)"
arch=('x86_64')
url="https://developer.gnome.org/notification-spec/"
license=('LGPL')
depends=("${pkgname#lib32-}" 'lib32-gdk-pixbuf2')
makedepends=('gcc-multilib' 'git' 'gnome-common' 'gobject-introspection' 'lib32-gtk3')
-_commit=6b03c47e04e556691445590c15d594aaff5a1066
+_commit=c954cabaad9e224c0c6129032d824012d332c11b # tags/0.7.7^0
source=("git://git.gnome.org/libnotify#commit=$_commit")
sha512sums=('SKIP')
@@ -21,6 +21,11 @@ prepare() {
NOCONFIGURE=1 ./autogen.sh
}
+pkgver() {
+ cd ${pkgname#lib32-}
+ git describe --tags | sed 's/-/+/g'
+}
+
build() {
# Modify environment to generate 32-bit ELF. Respects flags defined in makepkg.conf
export CFLAGS="-m32 ${CFLAGS}"