summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authororumin2017-08-11 15:41:10 +0900
committerorumin2017-08-11 15:41:10 +0900
commitbe83fd729f9d9141f6f7385db21cfdcb427e41f9 (patch)
tree4ba9ed9c1ab37fe7632bd045039a1c58c03e8cce /PKGBUILD
downloadaur-be83fd729f9d9141f6f7385db21cfdcb427e41f9.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52b09ef13f92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: orumin <dev at orum.in>
+
+pkgname=lib32-libraw
+_basename=libraw
+pkgver=0.18.2
+pkgrel=1
+pkgdesc="A library for reading RAW files obtained from digital photo cameras (CRW/CR2, NEF, RAF, DNG, and others) (32-bit)"
+arch=('x86_64')
+url="http://www.libraw.org/"
+license=(CDDL LGPL)
+depends=(lib32-lcms2 lib32-jasper)
+source=("http://www.libraw.org/data/LibRaw-${pkgver}.tar.gz")
+sha256sums=('ce366bb38c1144130737eb16e919038937b4dc1ab165179a225d5e847af2abc6')
+
+build() {
+ cd LibRaw-$pkgver
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure --prefix=/usr \
+ --build=i686-pc-linux-gnu --libdir=/usr/lib32 \
+ --disable-examples
+ make
+}
+
+package() {
+ cd LibRaw-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ rm -rf "${pkgdir}"/usr/include
+ rm -rf "${pkgdir}"/usr/share
+}