summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGicu GORODENCO2015-06-21 23:55:04 +0200
committerGicu GORODENCO2015-06-21 23:55:04 +0200
commitc99335cc80ba12427a4b3d0ace51f053ec2ae8ca (patch)
treed84e4fc8c2aadc743babc5433a39aa0a9a13158d /PKGBUILD
downloadaur-c99335cc80ba12427a4b3d0ace51f053ec2ae8ca.tar.gz
v2.4.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61e8a04b1bde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Gicu Gorodenco <cyclopsihus 'at' gmail 'dot' com>
+# Contributor: rafael ff1 (aka josephgbr)
+_pkgbasename=libsigc++
+pkgname=lib32-$_pkgbasename
+pkgver=2.4.1
+pkgrel=1
+pkgdesc="Libsigc++ implements a full callback system for use in widget libraries - V2 (32 bit)"
+arch=('x86_64')
+url="http://libsigc.sourceforge.net/"
+license=('LGPL')
+depends=("$_pkgbasename")
+makedepends=('gcc-multilib')
+options=(!libtool !emptydirs)
+source=(http://ftp.gnome.org/pub/GNOME/sources/${_pkgbasename}/${pkgver:0:3}/${_pkgbasename}-${pkgver}.tar.xz)
+sha256sums=('540443492a68e77e30db8d425f3c0b1299c825bf974d9bfc31ae7efafedc19ec')
+
+build() {
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+ ./configure --prefix=/usr --libdir=/usr/lib32 CXX='g++ -m32'
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+ sed -i -e 's/^doc_subdirs/#doc_subdirs/' Makefile
+ make DESTDIR="${pkgdir}" install
+ rm -rf ${pkgdir}/usr/include
+}