summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2020-08-04 10:05:22 -0400
committerVincent Grande2020-08-04 10:05:22 -0400
commit830b76b05eba395a268ee0b8543e5005d172bfb7 (patch)
tree702dbdb74ea5af2d71488e65f464f7c596775b68 /PKGBUILD
parenta13c7eb2185dc04295e782fefb28a88f67df28a3 (diff)
downloadaur-lib32-libunwind-git.tar.gz
mirror official repo pkgbuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD77
1 files changed, 48 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 42c14d87f007..a19d8460a4ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,63 @@
-# Maintainer: Moritz Lipp <mlq@pwmt.org>
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Laurent Carlier <lordheavym@gmail.com>
+# Contributor: Lone_Wolf <lonewolf at xs4all dot nl>
+# Contributor: Moritz Lipp <mlq@pwmt.org>
+
+_pkgbasename=libunwind
pkgname=lib32-libunwind-git
-pkgver=65ac867
+pkgver=1.5
pkgrel=1
-pkgdesc="Portable and efficient C programming interface (API) to determine the call-chain of a program"
-arch=('i686' 'x86_64')
-url="http://www.nongnu.org/libunwind/"
+pkgdesc="Portable and efficient C programming interface (API) to determine the call-chain of a program (32-bit)"
+arch=('x86_64')
+url="https://www.nongnu.org/libunwind/"
license=('GPL')
-makedepends=('git' 'texlive-core')
-depends=('glibc' 'libunwind-git')
-provides=('lib32-libunwind')
-conflicts=('lib32-libunwind')
+provides=(lib32-libunwind)
+conflicts=(lib32-libunwind)
+makedepends=('gcc-multilib')
+depends=('lib32-gcc-libs' 'libunwind' 'lib32-xz')
+source=("git+https://github.com/libunwind/libunwind.git")
+sha512sums=('SKIP')
+validpgpkeys=('SKIP') # Dave Watson <davejwatson@fb.com> , project admin for unwind
-source=("${pkgname}::git+git://git.sv.gnu.org/libunwind.git")
-sha1sums=('SKIP')
+pkgver() {
+ cd libunwind
+ git describe --tags | sed 's/-/+/g'
+}
-build() {
- cd "$srcdir/$pkgname"
+prepare() {
+ cd libunwind
- autoreconf -i
- CFLAGS="-m32 -U_FORTIFY_SOURCE" LDFLAGS="-m32" ./configure --prefix=/usr \
- --libdir=/usr/lib32 --target=i686-pc-linux-gnu
- make
+ NOCONFIGURE=1 ./autogen.sh
}
-check() {
- cd "$srcdir/$pkgname"
- PATH=/usr/bin:$PATH make check || return 0
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+
+ cd libunwind
+ ./configure \
+ --build=i686-pc-linux-gnu \
+ --host=i686-pc-linux-gnu \
+ --prefix=/usr \
+ --libdir=/usr/lib32 \
+ --disable-documentation
+ make
+
}
-package() {
- cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir/" install
+#check() {
+# cd "$srcdir/libunwind"
+ # This function is ``supposed'' to fail. Upstream know, but haven't fixed it.
+# make check || :
+#}
+package() {
+ cd libunwind
+ make DESTDIR="$pkgdir" install
+
+ # this build only provides multilib binary for x86 on x86_64 , remove all includes for other architectures
find $pkgdir/usr/include/*.h -not -name "*x86*" -exec rm -f {} \;
}
-pkgver() {
- cd "$srcdir/$pkgname"
- local ver="$(git describe --long --always)"
- printf "%s" "${ver//-/.}"
-}
-
# vim:set ts=2 sw=2 et:
+