summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2020-08-17 10:27:07 -0400
committerVincent Grande2020-08-17 10:27:07 -0400
commitc2d281e7e61ede8584f14fb6b850c70a1914d781 (patch)
tree88daf671752c592a36c6befa6cdfbb0291451208 /PKGBUILD
parent68f12ecb7fc0afbdc8c1ccae7232573b2615d825 (diff)
downloadaur-c2d281e7e61ede8584f14fb6b850c70a1914d781.tar.gz
quick fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2fb096c306a..8d7cb032a2f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,8 +14,7 @@ provides=(lib32-libx11)
conflicts=(lib32-libx11)
license=('custom:XFREE86')
source=("git+https://gitlab.freedesktop.org/xorg/lib/libx11.git")
-sha512sums=('SKIP'
- 'SKIP')
+sha512sums=('SKIP')
validpgpkeys=('SKIP') # Alan Coopersmith <alanc@freedesktop.org>
validpgpkeys+=('SKIP') # Matthieu Herrb <matthieu.herrb@laas.fr>
validpgpkeys+=('SKIP') # Matt Turner <mattst88@gmail.com>
@@ -25,7 +24,8 @@ build() {
export CC="gcc -m32"
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
- cd libX11-${pkgver}
+ cd libx11
+ NOCONFIGURE=1 ./autogen.sh
./configure --prefix=/usr --disable-static --disable-xf86bigfont \
--libdir=/usr/lib32 --disable-specs
make
@@ -38,7 +38,7 @@ build() {
#}
package() {
- cd libX11-${pkgver}
+ cd libx11
make DESTDIR="${pkgdir}" install
rm -rf "${pkgdir}"/usr/{include,share}