summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDarvin Delgado2024-03-03 12:00:50 -0400
committerDarvin Delgado2024-03-03 12:00:50 -0400
commit8f6a12b33e670bc5e819f9a3455a5979614930f4 (patch)
tree9756cc031388e51d65a45264a4dd1ca16ecb59d9 /PKGBUILD
parente27a377b14967bd6e00838c2e20de8a9426fd442 (diff)
downloadaur-lib32-mangohud-git.tar.gz
enable mangoapp and add libxkbcommon as a makedep
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 16 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a0c1b273083..7bc269eabd08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,44 @@
# Maintainer: Darvin Delgado <dnmodder at gmail dot com>
+_pkgname=MangoHud
pkgname=lib32-mangohud-git
-pkgver=0.7.1.r0.g48d8426
+pkgver=0.7.1.r20.g5598fda
pkgrel=1
pkgdesc="32-bit libraries for MangoHud and MangoApp"
url='https://github.com/flightlessmango/MangoHud'
license=('MIT')
arch=('x86_64')
-makedepends=('git' 'glslang' 'lib32-cmocka' 'lib32-libglvnd' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako' 'vulkan-headers')
-depends=('lib32-dbus' 'lib32-gcc-libs' 'lib32-libx11' 'lib32-sdl2' 'lib32-vulkan-icd-loader')
-provides=('lib32-mangohud')
-conflicts=('lib32-mangohud')
-source=("$pkgname::git+$url")
+makedepends=('git' 'glfw' 'glslang' 'lib32-cmocka' 'lib32-libglvnd' 'lib32-libxrandr' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako' 'vulkan-headers')
+depends=('lib32-dbus' 'lib32-gcc-libs' 'lib32-glew' 'lib32-libx11' 'lib32-libxkbcommon' 'lib32-vulkan-icd-loader')
+provides=('lib32-mangohud' 'lib32-mangoapp')
+conflicts=('lib32-mangohud' 'lib32-mangoapp')
+source=("git+$url")
sha512sums=('SKIP')
pkgver() {
- cd $pkgname
+ cd $_pkgname
git describe --tags --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- local meson_options=(
- --wrap-mode=nofallback
- -Dinclude_doc=false
- -Dwith_wayland=enabled
- $pkgname
- )
-
export CC="gcc -m32"
export CXX="g++ -m32"
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
export LLVM_CONFIG="/usr/bin/llvm-config32"
- arch-meson "${meson_options[@]}" build --libdir lib32
+ arch-meson "$_pkgname" build \
+ -Dmangoapp_layer=true \
+ -Dinclude_doc=false \
+ --wrap-mode=nofallback \
+ --libdir lib32
meson compile -C build
}
package() {
- meson install -C build --tags runtime --destdir "$pkgdir"
+ meson install -C build --tags runtime,mangoapp --destdir "$pkgdir"
- install -Dm 0664 "$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
rm -rf "$pkgdir/usr/bin"
+
+ install -Dm 0644 "$_pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}