summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLW-archlinux2018-08-04 23:29:31 +0200
committerLW-archlinux2018-08-04 23:29:31 +0200
commit3eb9e841d8191425c06833bf05828ffa183345f4 (patch)
tree1b39a2dfcf13d30fd6e2b6381aa66032375a72f9 /PKGBUILD
parentffe23b8027029a1a92a469c108a5582e92e779e7 (diff)
downloadaur-3eb9e841d8191425c06833bf05828ffa183345f4.tar.gz
remove files in /usr/bin, see https://bugs.freedesktop.org/show_bug.cgi?id=107487
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63b89b400ce5..5bd75f3d2aae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@
pkgbase=lib32-mesa-git
pkgname=('lib32-mesa-git')
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=18.2.0_devel.103089.ff6db94c18
-pkgrel=2
+pkgver=18.3.0_devel.103997.c3325097be
+pkgrel=1
arch=('x86_64')
makedepends=('python2-mako' 'lib32-libxml2' 'lib32-libx11' 'xorgproto'
'lib32-gcc-libs' 'lib32-libvdpau' 'lib32-libelf' 'lib32-llvm-svn' 'git' 'lib32-libgcrypt' 'lib32-systemd'
@@ -80,7 +80,8 @@ build () {
-D lmsensors=true \
-D osmesa=gallium \
-D shared-glapi=true \
- -D valgrind=false
+ -D valgrind=false \
+ -D tools=[]
meson configure _build
ninja -C _build
}
@@ -90,6 +91,11 @@ package_lib32-mesa-git () {
DESTDIR="$pkgdir" ninja -C _build install
+ # https://bugs.freedesktop.org/show_bug.cgi?id=107487
+ # removing those files and the /usr/bin/ folder
+ rm "$pkgdir"/usr/bin/intel_dump_gpu "$pkgdir"/usr/bin/intel_sanitize_gpu
+ rmdir "$pkgdir"/usr/bin
+
# remove files provided by mesa-git
rm -rf "$pkgdir"/etc
rm -rf "$pkgdir"/usr/include