summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2018-04-18 21:26:11 -0400
committerAndrew Sun2018-04-18 21:26:11 -0400
commit509b2db23dc0520d1f895c1d9acbc03207ebd746 (patch)
treecdeace386300e9a096dbf23618181d52bdd5b599 /PKGBUILD
downloadaur-509b2db23dc0520d1f895c1d9acbc03207ebd746.tar.gz
add lib32-mpdecimal (version 2.4.2)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2453c858570e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+
+pkgname=lib32-mpdecimal
+_pkgbasename=mpdecimal
+pkgver=2.4.2
+pkgrel=1
+pkgdesc="Package for correctly-rounded arbitrary precision decimal floating point arithmetic"
+arch=('x86_64')
+url="http://www.bytereef.org/mpdecimal/index.html"
+license=('custom')
+depends=('lib32-glibc' 'lib32-gcc-libs')
+source=("http://www.bytereef.org/software/${_pkgbasename}/releases/${_pkgbasename}-${pkgver}.tar.gz")
+sha512sums=('eb18ad53b81b93c469db4d915bbb3fae21b36ad82a88e01fef3a6946ac5f50b54376e259a5ecbe23836f1efd59d226b942ecdee87eaba7f9e75cdcaaa9499ef7')
+
+prepare() {
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+ autoreconf -fiv
+}
+
+build() {
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+ export LDFLAGS+=' -m32'
+
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib32
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/{bin,include,share}
+}