summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGabriel-Andrew Pollo Guilbert2015-06-18 14:07:08 -0400
committerGabriel-Andrew Pollo Guilbert2015-06-18 14:07:08 -0400
commitb081c38190779b28c4a36e3d8e47c14553a475c1 (patch)
tree9f866fd8a15c93fe01be32181cb583caf0163e5c /PKGBUILD
downloadaur-b081c38190779b28c4a36e3d8e47c14553a475c1.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a82c1ee2151b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gabriel-Andrew Pollo Guilbert <gabriel14_wii@hotmail.com>
+
+pkgname=lib32-oniguruma
+pkgver=5.9.6
+pkgrel=1
+pkgdesc='Oniguruma is a regular expressions library.'
+arch=('x86_64')
+url='http://www.geocities.jp/kosako3/oniguruma/'
+license=('BSD')
+depends=('oniguruma')
+source=("http://www.geocities.jp/kosako3/oniguruma/archive/onig-${pkgver}.tar.gz")
+sha256sums=('d5642010336a6f68b7f2e34b1f1cb14be333e4d95c2ac02b38c162caf44e47a7')
+
+build() {
+ cd onig-${pkgver}
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure --libdir='/usr/lib32'
+
+ make
+}
+
+package() {
+ cd onig-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}
+
+