summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2019-11-19 14:10:05 -0800
committerLlewelyn Trahaearn2019-11-19 14:10:05 -0800
commita265e7ee54214fc5662cbd5e81fa6af04d5fce17 (patch)
tree517bb74b7799db21ae099c044da3c7bf4c8ea6bd /PKGBUILD
parentc573f43f9522d773066887ee7d8ce7d83a9bcba9 (diff)
downloadaur-lib32-qt4.tar.gz
Include patches to remedy build failure against GCC 9.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 12 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9859dc598997..98720afb86e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=lib32-qt4
pkgver=4.8.7
-pkgrel=14
+pkgrel=15
pkgdesc='A cross-platform application and UI framework (32-bit)'
arch=('x86_64')
url='http://www.qt.io'
@@ -35,6 +35,8 @@ source=("https://download.qt.io/archive/qt/4.8/${pkgver}/${_pkgfqn}.tar.gz"
'l-qclipboard_fix_recursive.patch'
'l-qclipboard_delay.patch'
'qt4-gcc6.patch'
+ 'qt4-gcc8.patch'
+ 'qt4-gcc9.patch'
'qt4-glibc-2.25.patch'
'qt4-icu59.patch'
'qt4-openssl-1.1.patch')
@@ -48,6 +50,8 @@ sha512sums=('f9f81a2e7205e1fd05c8d923dc73244f29aa33f951fa6b7c5c8193449328b370847
'bd63961bcb695beebe8686142b84bff7702db4d85d737f5c2da927252b931700d03602f80048223cbbb05d85a5ddb9cb818321d756577f84843690b318f0c413'
'0215f81fd0ed3483d1f79f46a53d9378f7462901410f4bc3f235325974c155454b0e75cba5222180e5ca62099cba7b80419b5fab86380ac6d951b9ae12714444'
'efe8e1842882b784a14ba137bc6a8a579d5133e579f98c61674f5d3d9b79ff8e895775a79fcf757f7726377cd221396a678d181fa069416b0760a5241d39845a'
+ '503376d873a89ab0a31a71ea82434689725c5f97610ba0e37a2f4e3bcb41fe46b790bc2f04d488dcfdd06c4a1a9e752cf0baf7e23f99b1707852953704031450'
+ '8bb0f9f14f8ef751baac1048455e5238d0fd7e7464b09eb30cc131d9241102e9a6c35742f55e871f844fcbfa56729a692ed2f57103b7835905e089932ad4a47d'
'a19e76d64bbbf148b088e3531135dc3ababd63ea8e71147dcf7d2966802abb2d83b839766882040e5c9efdea2e364d48bc38aa712dd35b850383c7747ffa9745'
'483b382da8ad57f9792df1ad0c85948992d8293819c2774a381544235d9b6a7498b12beb3f9d7d06c4a814f8ded514973453314d71381368148d2fcbbf854e65'
'ce9bb1c9657660e7b6181271f4264d3f6e22788f13113dd6f97b73c7172d7dcea1d7daf5fe13d147643e89d50aaca23da70657ec217d616144aa79045524db5c')
@@ -97,6 +101,12 @@ prepare() {
# Fix build with GCC6 (Fedora)
patch -p1 -i "$srcdir"/qt4-gcc6.patch
+ # Fix build with GCC-8.3
+ patch -Np0 -i "$srcdir"/qt4-gcc8.patch
+
+ # Fix build with GCC9
+ patch -Np0 -i "$srcdir"/qt4-gcc9.patch
+
# Fix build of Qt4 applications with glibc 2.25 (Fedora)
patch -p1 -i "$srcdir"/qt4-glibc-2.25.patch
@@ -136,6 +146,7 @@ build() {
-nomake demos \
-nomake examples \
-nomake docs \
+ -xmlpatterns \
-silent \
-no-rpath \
-optimized-qmake \