summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2017-03-13 12:11:59 -0700
committerLlewelyn Trahaearn2017-03-13 12:11:59 -0700
commita37409066481332fb94095305f138967117d551c (patch)
tree8a0172de8b9ee32bcc82163b54821c1bd9e0bfda /PKGBUILD
parent90c8e6bde2065eb82a04268aafa4d08290b0dbb1 (diff)
downloadaur-a37409066481332fb94095305f138967117d551c.tar.gz
Include new patch from [Extra].
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d6df5748f3f..78f0ceb64b94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=lib32-qt4
pkgver=4.8.7
-pkgrel=9
+pkgrel=10
pkgdesc='A cross-platform application and UI framework (32-bit)'
arch=('x86_64')
url='http://qt-project.org/'
@@ -33,7 +33,8 @@ source=("http://download.qt.io/official_releases/qt/4.8/${pkgver}/${_pkgfqn}.tar
'disable-sslv3.patch'
'l-qclipboard_fix_recursive.patch'
'l-qclipboard_delay.patch'
- 'qt4-gcc6.patch')
+ 'qt4-gcc6.patch'
+ 'qt4-glibc-2.25.patch')
sha512sums=('f9f81a2e7205e1fd05c8d923dc73244f29aa33f951fa6b7c5c8193449328b37084796b9b71ad0c317e4e6fd00017c10ea5d67b1b2032551cde00548522218125'
'4a8f828c79bde81ab1e39c9eaba4ef553582d85b62d6d182dda02820c4c8e046de6a25cc77d228955ed37fbc5b55f697a0a464af0bb3e171849851639e9ef4ee'
'b4eced1fe34f09baa987be59fd21a02f4209551f491ae113c9d1cc3c44b00494a909808e22db306bcae0ee4c4f996097ce2c23994b2ac067cf9f599da5a5fc71'
@@ -43,7 +44,8 @@ sha512sums=('f9f81a2e7205e1fd05c8d923dc73244f29aa33f951fa6b7c5c8193449328b370847
'922919e5331b392f4a189e2745fd404c98baac797ba543a78c27e4fa7ec4067625f03c03b6c3c943327ee82cf077804ce3b8eb1684a2e265714b6188f8dbae74'
'bd63961bcb695beebe8686142b84bff7702db4d85d737f5c2da927252b931700d03602f80048223cbbb05d85a5ddb9cb818321d756577f84843690b318f0c413'
'0215f81fd0ed3483d1f79f46a53d9378f7462901410f4bc3f235325974c155454b0e75cba5222180e5ca62099cba7b80419b5fab86380ac6d951b9ae12714444'
- 'efe8e1842882b784a14ba137bc6a8a579d5133e579f98c61674f5d3d9b79ff8e895775a79fcf757f7726377cd221396a678d181fa069416b0760a5241d39845a')
+ 'efe8e1842882b784a14ba137bc6a8a579d5133e579f98c61674f5d3d9b79ff8e895775a79fcf757f7726377cd221396a678d181fa069416b0760a5241d39845a'
+ '01fbcfb8e0ad22eb614d1a55fc6db5794f395dea6a2f155e974a9b10c91cb5551cc0b30ba84c5b32f520eab985572101901ad5664849d3e96a2de6dba1827868')
prepare() {
cd $_pkgfqn
@@ -89,7 +91,10 @@ prepare() {
# Fix build with GCC6 (Fedora)
patch -p1 -i "$srcdir"/qt4-gcc6.patch
-}
+
+ # Fix build of Qt4 applications with glibc 2.25 (Fedora)
+ patch -p1 -i "$srcdir"/qt4-glibc-2.25.patch
+ }
build() {
cd $_pkgfqn