summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYurii Kolesnykov2018-10-03 20:28:49 +0300
committerYurii Kolesnykov2018-10-03 20:28:49 +0300
commitda7f3f840f34f345fdc4edc246cf71f9c8db32e2 (patch)
treee7403e1e52b21c4f5855ee00968dac8c8fe650e0 /PKGBUILD
parented07f9045ea63bdbb196447aedd2ec2a26c7e177 (diff)
downloadaur-da7f3f840f34f345fdc4edc246cf71f9c8db32e2.tar.gz
239.1099
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 25 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 041e0298020f..bd236eb26403 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=lib32-systemd-git
_pkgname=lib32-systemd
_pkgbasename=systemd
-pkgver=239.1021
+pkgver=239.1099
pkgrel=1
pkgdesc='system and service manager (32-bit, git version)'
arch=('x86_64')
@@ -18,7 +18,7 @@ replaces=("$_pkgname")
conflicts=("$_pkgname")
makedepends=('gcc-multilib' 'git' 'gperf' 'intltool' 'lib32-acl' 'lib32-bzip2'
'lib32-curl' 'lib32-dbus' 'lib32-gcc-libs' 'lib32-glib2'
- 'lib32-gnutls' 'lib32-libelf' 'lib32-libidn' 'lib32-pcre2'
+ 'lib32-gnutls' 'lib32-libelf' 'lib32-libidn2' 'lib32-pcre2'
'libxslt' 'meson')
options=('strip' '!distcc' '!ccache')
source=('git+https://github.com/systemd/systemd')
@@ -39,15 +39,29 @@ build() {
export CXX="g++ -m32"
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
- local timeservers=({0..3}.arch.pool.ntp.org)
+ local _timeservers=({0..3}.arch.pool.ntp.org)
+ local _nameservers=(
+ # We use these public name services, ordered by their
+ # privacy policy (hopefully):
+ # * Cloudflare (https://1.1.1.1/)
+ # * Quad9 without filtering (https://www.quad9.net/)
+ # * Google (https://developers.google.com/speed/public-dns/)
+ 1.1.1.1
+ 9.9.9.10
+ 8.8.8.8
+ 2606:4700:4700::1111
+ 2620:fe::10
+ 2001:4860:4860::8888
+ )
- local meson_options=(
- --libexecdir /usr/lib32
- --libdir /usr/lib32
+ local _meson_options=(
+ --libexecdir /usr/lib32
+ --libdir /usr/lib32
-Daudit=false
- -Dgnuefi=false
+ -Dgnu-efi=false
-Dima=false
+ -Dlibidn2=true
-Dlz4=false
-Dblkid=false
-Dkmod=false
@@ -62,25 +76,24 @@ build() {
-Dhtml=false
-Ddbuspolicydir=/usr/share/dbus-1/system.d
- -Ddefault-dnssec=no
# TODO(dreisner): consider changing this to unified
-Ddefault-hierarchy=hybrid
-Ddefault-kill-user-processes=false
-Dfallback-hostname='archlinux'
- -Dntp-servers="${timeservers[*]}"
+ -Dntp-servers="${_timeservers[*]}"
+ -Ddns-servers="${_nameservers[*]}"
-Drpmmacrosdir=no
-Dsysvinit-path=
-Dsysvrcnd-path=
)
- arch-meson "$_pkgbasename" build "${meson_options[@]}"
+ arch-meson "$_pkgbasename" build "${_meson_options[@]}"
ninja -C build
}
check() {
- cd build
- meson test
+ meson test -C build
}
package() {
@@ -89,4 +102,3 @@ package() {
rm -rf "${pkgdir}"/{etc,var}
rm -rf "${pkgdir}"/usr/{bin,include,lib,share}
}
-