summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2015-07-09 10:22:04 +0200
committerMaxime Gauduin2015-07-09 10:22:04 +0200
commit57c874d012cc5bb139333ef4ccdca5e55f6b7f43 (patch)
treeb0b0f63184d80dc9ca0c600bdf84b75426466683 /PKGBUILD
downloadaur-57c874d012cc5bb139333ef4ccdca5e55f6b7f43.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e5640537e43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: AndyRTR <andyrtr@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=lib32-unixodbc
+pkgver=2.3.2
+pkgrel=1
+pkgdesc='ODBC is an open specification for providing application developers with a predictable API with which to access Data Sources'
+arch=('x86_64')
+url='http://www.unixodbc.org/'
+license=('GPL2' 'LGPL2.1')
+depends=('lib32-libltdl' 'unixodbc')
+makedepends=('gcc-multilib')
+groups=('pipelight-libs')
+source=("http://www.unixodbc.org/unixODBC-$pkgver.tar.gz")
+sha256sums=('9c3459742f25df5aa3c10a61429bde51a6d4f11552c03095f1d33d7eb02b5c9a')
+
+build() {
+ cd unixODBC-${pkgver}
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure \
+ --prefix='/usr' \
+ --libdir='/usr/lib32' \
+ --sysconfdir='/etc'
+ make
+}
+
+package() {
+ cd unixODBC-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/{etc,usr/{bin,include,share}}
+}
+
+# vim: ts=2 sw=2 et: