summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabien Dubosson2015-05-29 13:15:14 +0200
committerFabien Dubosson2015-05-29 13:15:14 +0200
commit9a7c588d296df12afe1391a53bef88057b5d119d (patch)
treee76f70bb61d6534b57aeb254e802d918b45e5184 /PKGBUILD
downloadaur-9a7c588d296df12afe1391a53bef88057b5d119d.tar.gz
Move 'lib32-wfdb' into separate repo for AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 63 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..871064174db8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Fabien Dubosson <fabien.dubosson@gmail.com>
+
+_pkgname='wfdb'
+pkgname="lib32-${_pkgname}"
+pkgver="10.5.23"
+pkgrel="2"
+pkgdesc="Software from PhysioNet for viewing, analyzing, and creating recordings of physiologic signals"
+url="http://www.physionet.org/physiotools/wfdb.shtml"
+license=('GPL')
+arch=('x86_64')
+depends=('lib32-curl>=7.10' 'lib32-expat')
+provides=('wfdb')
+conflicts=('wfdb')
+optdepends=('wfdb-samples')
+makedepends=('gcc-multilib' 'chrpath')
+install="${_pkgname}.install"
+changelog="ChangeLog"
+source=("http://www.physionet.org/physiotools/${_pkgname}.tar.gz")
+md5sums=('0c4dd0bc86408709fe2364f6703c5c66')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr
+
+ # One of this variable is causing problem, no idea which or why
+ unset CHOST COMMAND_MODE CPPFLAGS CXXFLAGS MAKEFLAGS
+
+ make MFLAGS='-m32'
+
+ builddir="${srcdir}/${_pkgname}-${pkgver}/build"
+
+ # Adapt some compile-time hardcoded paths
+ sed -i "s+${builddir}+/usr/share/wfdb+g" \
+ "${builddir}/bin/setwfdb" \
+ "${builddir}/bin/cshsetwfdb"
+ sed -i "s+${builddir}+/usr+g" \
+ "${builddir}/bin/hrfft"\
+ "${builddir}/bin/hrlomb"\
+ "${builddir}/bin/hrmem"\
+ "${builddir}/bin/hrplot"
+
+ # Remove RPATH and RUNPATH from executables
+ for ex in `find "${builddir}/bin/" -exec file {} \; | grep ELF | cut -d':' -f1`;
+ do
+ chrpath -d "$ex"
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ mkdir -p "${pkgdir}/usr"
+ cp -R "build/bin" "${pkgdir}/usr/"
+ cp -R "build/include" "${pkgdir}/usr/"
+ cp -R "build/lib" "${pkgdir}/usr/lib32"
+ cp -R "build/share" "${pkgdir}/usr/"
+
+ # Why? Why 64???
+ cp -R build/lib64/* "${pkgdir}/usr/lib32"
+}
+
+# vim:set ts=4 sw=4 et: