summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Demers2020-06-28 11:47:37 -0400
committerAlexandre Demers2020-06-28 11:47:37 -0400
commit0edde7994bd0a8ad6085f4aa065c18c37fe308db (patch)
tree45c3bae5a3eeb5c77d8f0f702ee2425038dbde63 /PKGBUILD
parentabd651098d5ebf8d26d84bb7cc1ae4414b15f5d5 (diff)
downloadaur-0edde7994bd0a8ad6085f4aa065c18c37fe308db.tar.gz
Reintroduce lib32-x264. Needed by other AUR packages.
I can't find why this package was removed from the package list searching in the last few months in aur-request mailing list. It shouldn't have been. I'm taking ownership for now. Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8aab7e063cb7..d17ccf028b99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,21 @@
-# Maintainer: GodronGR <ntheo1979@gmail.com>
+# Maintainer: Alexandre Demers <alexandre.f.demers@gmail.com>
+# Contributor: GodronGR <ntheo1979@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: damir <damir@archlinux.org>
# Contributor: Paul Mattal <paul@archlinux.org>
+_pkgbasename=x264
pkgname=lib32-x264
pkgver=0.159.r2999.296494a
-pkgrel=2
+pkgrel=3
epoch=3
-pkgdesc='Open Source H264/AVC video encoder (lib32)'
+pkgdesc='Open Source H264/AVC video encoder (32 bit)'
arch=('x86_64')
url='https://www.videolan.org/developers/x264.html'
license=('GPL')
-depends=('x264')
+depends=('x264' 'lib32-glibc')
makedepends=('git' 'l-smash' 'nasm' 'lib32-gcc-libs')
provides=('lib32-libx264' 'libx264.so')
conflicts=('lib32-libx264' 'lib32-libx264-10bit' 'lib32-libx264-all')
@@ -43,12 +45,12 @@ build() {
../x264/configure \
--prefix='/usr' \
+ --libdir=/usr/lib32 \
+ --host=i686-linux-gnu \
--enable-shared \
--enable-pic \
--enable-lto \
--disable-avs \
- --libdir=/usr/lib32 \
- --host=i686-linux-gnu \
--extra-cflags="-flto -ffat-lto-objects"
make
}