summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlorenzo2017-08-24 20:27:31 +0200
committerlorenzo2017-08-24 20:27:31 +0200
commit376b40348743c2525a4069af4039c189193d4452 (patch)
tree9f6593dfea051586097925b98de5ef4f58711c88 /PKGBUILD
downloadaur-376b40348743c2525a4069af4039c189193d4452.tar.gz
First version of the lib32-x265 package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6b018f1794f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: kfgz <kfgz@interia.pl>
+_basename=x265
+pkgname=lib32-x265
+pkgver=2.5
+pkgrel=1
+pkgdesc='Open Source H265/HEVC video encoder'
+arch=('x86_64')
+url='https://bitbucket.org/multicoreware/x265'
+license=('GPL')
+depends=('gcc-libs-multilib')
+makedepends=('yasm' 'cmake')
+provides=('libx265.so')
+source=("https://bitbucket.org/multicoreware/x265/downloads/x265_${pkgver}.tar.gz")
+sha256sums=('2e53259b504a7edb9b21b9800163b1ff4c90e60c74e23e7001d423c69c5d3d17')
+
+prepare() {
+ cd x265_${pkgver}
+
+ if [[ -d build-8 ]]; then
+ rm -rf build-8
+ fi
+ mkdir build-8
+}
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ cd x265_${pkgver}/build-8
+
+ cmake ../source \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_LIBRARY_PATH='/usr/lib32' \
+ -DENABLE_SHARED='TRUE' \
+ -DENABLE_HDR10_PLUS='TRUE' -DHAVE_STRTOK_R='TRUE'
+ make
+}
+
+package() {
+ cd x265_${pkgver}/build-8
+
+ make DESTDIR="${pkgdir}" install
+ cd $pkgdir/usr
+ rm bin include -R
+ mv lib lib32
+}
+
+# vim: ts=2 sw=2 et: