summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072022-01-27 15:53:57 +0100
committersL1pKn072022-01-27 15:53:57 +0100
commit5d814ed1b2075d460685d93ff6200232a36f3492 (patch)
tree957d88ded3b869a3ebcb620b5637514e505680e4 /PKGBUILD
parentbd7d097b6ce6d7aeac7224c194d4472f1b19d380 (diff)
downloadaur-5d814ed1b2075d460685d93ff6200232a36f3492.tar.gz
fix license url
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08079c555697..1736aad9d445 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,18 @@ pkgver=0.4.1
pkgrel=1
pkgdesc="Utility libraries for XC Binding - client and window-manager helpers for ICCCM. (32-bits)"
arch=('x86_64')
-url="https://xcb.freedesktop.org"
+url='https://xcb.freedesktop.org'
license=('custom')
depends=('lib32-libxcb'
- 'xcb-util-wm'
+ "xcb-util-wm=${pkgver}"
)
makedepends=('xorg-util-macros')
source=("https://xcb.freedesktop.org/dist/xcb-util-wm-${pkgver}.tar.bz2"
- 'LICENSE::https://git.archlinux.org/svntogit/packages.git/plain/trunk/LICENSE?h=packages/xcb-util-wm')
+ 'LICENSE::https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/xcb-util-wm/trunk/LICENSE'
+ )
sha512sums=('cd1b3bcf9fcfc52e329ddc42b370d50dcf7d473c8e94f01cf7ea7fdbe0dc9176790890214eecb2a8ac43405f4938c121e38d282ae988cd8e90a6610d214ef326'
- '62f83468f9d9503a5a8c1ebaac78cbaefe3c485f8bfd7192817ec59254872fe2914ed66ae8b9e7f7a6ef5af283048c11390f44eb8f0f70b1c136ef5c75282e8c')
+ '62f83468f9d9503a5a8c1ebaac78cbaefe3c485f8bfd7192817ec59254872fe2914ed66ae8b9e7f7a6ef5af283048c11390f44eb8f0f70b1c136ef5c75282e8c'
+ )
prepare() {
mkdir -p build
@@ -25,7 +27,7 @@ build() {
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
cd build
- ../xcb-util-wm-${pkgver}/configure \
+ ../"xcb-util-wm-${pkgver}"/configure \
--prefix=/usr \
--libdir=/usr/lib32 \
--host=i686-linux-gnu \
@@ -37,8 +39,7 @@ build() {
package() {
make -C build DESTDIR="${pkgdir}" install
- install -Dm644 "${srcdir}/LICENSE" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
rm -fr "${pkgdir}/usr/include"
}