summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthias Van Gestel2020-01-20 13:48:46 +0100
committerMatthias Van Gestel2020-01-20 13:48:46 +0100
commitc4eb366795a0ac80f043e798b92c834b47f554cc (patch)
tree1580592e1d4a96aa28de61e5b7caf6d4a1054eb3 /PKGBUILD
downloadaur-c4eb366795a0ac80f043e798b92c834b47f554cc.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9f448daa1d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: fenrig <fenrig.linux at outlook.com>
+pkgname=lib_amxj-git
+pkgver=v0.0.3.r3.g58289ff
+pkgrel=1
+pkgdesc="JSON Reader/generation - JSON string variant"
+arch=('any')
+url="https://gitlab.com/proj_amx_01/libraries/lib_amxj"
+license=('MIT')
+
+depends=(
+ 'lib_amxc'
+ 'yajl'
+)
+makedepends=(
+)
+provides=(
+ 'lib_amxj'
+)
+conflicts=(
+ 'lib_amxj'
+)
+
+gitbranch="master"
+
+source=("${pkgname}::git+https://gitlab.com/proj_amx_01/libraries/lib_amxj.git#branch=${gitbranch}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DEST="${pkgdir}/" INSTALL_LIB_DIR="/lib" install
+}