summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRod Kay2021-06-22 09:56:44 +1000
committerRod Kay2021-06-22 09:56:44 +1000
commit19210ab07dfbdc6ed002f7d8dce25e444b680ed4 (patch)
tree068707c13c18288e97a96f8bdd7639fe6db20b35 /PKGBUILD
parentd4964fddc089b4d065588773de2e41a48332346e (diff)
downloadaur-19210ab07dfbdc6ed002f7d8dce25e444b680ed4.tar.gz
Install the licenses.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2cd0707dd665..4a06d84a2de9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgdesc="A high performance semantic engine for the Ada programming language."
arch=('i686' 'x86_64')
url="https://github.com/AdaCore/libadalang"
-license=('GPL')
+license=('GPL3' 'custom')
depends=("gnatcoll-core" "gnatcoll-iconv" "gnatcoll-gmp")
makedepends=('gprbuild' 'python-setuptools' 'python-mako' 'python-funcy' 'python-e3-core' 'python-docutils')
@@ -43,6 +43,16 @@ package()
python ada/manage.py install --build-mode=prod "$pkgdir/usr"
+ # Install the license.
+ install -D -m644 \
+ "COPYING3" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING3"
+
+ # Install the custom license.
+ install -D -m644 \
+ "COPYING.RUNTIME" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME"
+
# Install the Python binding
cd build/python
python setup.py install --root="$pkgdir"