summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRod Kay2018-09-30 18:31:43 +1000
committerRod Kay2018-09-30 18:31:43 +1000
commit2b97c344c347451cb1a0f4243e8ec11748720f6a (patch)
tree09424770f192d29f34ed84a850ff1e7c135a2567 /PKGBUILD
parent54ab5e8cfe3588d8f1fd12656ff3ebf66d02d61f (diff)
downloadaur-2b97c344c347451cb1a0f4243e8ec11748720f6a.tar.gz
Force use of GCC rather than Clang
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0a4a8a43924..94ef45a91179 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,8 +32,12 @@ build()
export PYTHONPATH=$srcdir/langkit-gpl-2018-src:$PYTHONPATH
+ # Clang has trouble compiling the Quex-generated lexer, so make sure
+ # GPRbuild chooses GCC.
+ gprconfig -o config.cgpr --batch --config=c,,,,GCC --config=ada,,,,
+
python2 ada/manage.py generate
- python2 ada/manage.py build
+ python2 ada/manage.py build --gargs="-R --config=$PWD/config.cgpr"
}