summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXiretza2021-07-18 12:03:44 +0200
committerXiretza2021-07-18 12:03:44 +0200
commit8737f9ad993cbb9e212d291f3fc90f0c03005f6a (patch)
tree8af2a0a3e6b7991683a69426a60b011802354be6 /PKGBUILD
parent1dc436dfd6438c5373b71ef382e3981c58e6e12e (diff)
downloadaur-8737f9ad993cbb9e212d291f3fc90f0c03005f6a.tar.gz
Build static libraries
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3ce90e8ae50..b3eadc5b896b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,7 +29,11 @@ build()
ADA_FLAGS="${ADA_FLAGS//-Werror=format-security}"
python manage.py generate
- python manage.py build --build-mode=prod --gargs="-R -cargs $ADA_FLAGS -largs $LDFLAGS -gargs"
+ python manage.py \
+ build \
+ --library-types=static,static-pic,relocatable \
+ --build-mode=prod \
+ --gargs="-R -cargs $ADA_FLAGS -largs $LDFLAGS -gargs"
make -C dev_manual html
}
@@ -38,7 +42,11 @@ package()
{
cd "$srcdir/$pkgname-$_upstream_ver-src"
- python manage.py install --build-mode=prod "$pkgdir/usr"
+ python manage.py \
+ install \
+ --library-types=static,static-pic,relocatable \
+ --build-mode=prod \
+ "$pkgdir/usr"
# Install the developers manual
cd dev_manual/_build/html
@@ -69,3 +77,4 @@ package()
mkdir -p "$pkgdir/usr/lib/ocaml/"
mv "$pkgdir/usr/ocaml" "$pkgdir/usr/lib/ocaml/libadalang"
}
+# vim: set et ts=2: