summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRod Kay2023-06-09 11:55:34 +1000
committerRod Kay2023-06-09 11:55:34 +1000
commitcf277c45985b1e256af7cdce6f82d3a7be90a8e2 (patch)
treea25fc43b99e8028a8497f16d2e2039e0192dd4b4 /PKGBUILD
parentd02fc14b11d434b7305e12bd40fbf6d2b1dab6bb (diff)
downloadaur-cf277c45985b1e256af7cdce6f82d3a7be90a8e2.tar.gz
Update to version '24.0w'.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 33 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00d5b2f8f4b5..83f977335128 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,33 @@
# Maintainer: xiretza <xiretza+aur@gmail.com>
# Maintainer: Rod Kay <rodakay5 at gmail dot com>
-pkgname=libadalang
epoch=2
-pkgver=23.0.0
-pkgrel=1
+pkgname=libadalang
+pkgver=24.0w
+pkgrel=1
pkgdesc="A high performance semantic engine for the Ada programming language."
-url="https://github.com/AdaCore/libadalang"
-arch=('i686' 'x86_64')
-license=('Apache')
-depends=('gnatcoll-gmp' 'langkit')
-makedepends=('gprbuild' 'python-setuptools' 'python-mako' 'python-funcy'
- 'python-e3-core' 'python-docutils' 'python-sphinx')
+url=https://github.com/AdaCore/libadalang
+arch=(i686 x86_64)
+license=(Apache)
+
+depends=(gnatcoll-gmp langkit)
+makedepends=(gprbuild
+ python-setuptools
+ python-mako
+ python-funcy
+ python-e3-core
+ python-docutils
+ python-sphinx)
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=("0655d2eb755b9789ebf2b1ecfe5189bd64a5a80471d008a2e7ad0e58b9b35350")
+source=(file:///opt/gnatstudio-sources/$pkgname-$pkgver-20230324-164A3-src.tar.gz)
+sha256sums=(87c64c60ee147a9ac27f997dcf071a7c143e85382202a18e5d8a0943fb87cc16)
build()
{
- cd "$srcdir/$pkgname-$pkgver"
+ cd $srcdir/$pkgname-$pkgver-20230428-16114-src
ADA_FLAGS="$CFLAGS"
ADA_FLAGS="${ADA_FLAGS//-Wformat}"
@@ -39,17 +45,19 @@ build()
python setup.py build
}
+
package()
{
- cd "$srcdir/$pkgname-$pkgver"
+ cd $srcdir/$pkgname-$pkgver-20230428-16114-src
python manage.py \
install \
--library-types=static,static-pic,relocatable \
--build-mode=prod \
- "$pkgdir/usr"
+ $pkgdir/usr
- # Install the developers manual
+ # Install the developers manual.
+ #
pushd dev_manual/_build/html
for file in $(find . -type f); do
@@ -59,17 +67,20 @@ package()
popd
# Install the license.
- install -D -m644 \
- "LICENSE" \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ #
+ install -D -m644 \
+ LICENSE.txt \
+ $pkgdir/usr/share/licenses/$pkgname/LICENSE.txt
# Install the Python binding
+ #
cd build/python
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python setup.py install --root=$pkgdir --optimize=1 --skip-build
- rm -fr "$pkgdir/usr/python"
+ rm -fr $pkgdir/usr/python
# Fix ocaml bindings location
- mkdir -p "$pkgdir/usr/lib/ocaml/"
- mv "$pkgdir/usr/ocaml" "$pkgdir/usr/lib/ocaml/libadalang"
+ #
+ mkdir -p $pkgdir/usr/lib/ocaml
+ mv $pkgdir/usr/ocaml $pkgdir/usr/lib/ocaml/libadalang
} \ No newline at end of file