summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPierre-Marie de Rodat2021-01-24 16:36:40 +0100
committerPierre-Marie de Rodat2021-01-24 16:36:40 +0100
commit86aeefb9920d066c1b568bd9475b5c4e29aa95af (patch)
treef9e7bb01ab04b8284fb443f73bfc477d05fa0319 /PKGBUILD
parent6ce0b5c00be8b4bd92250e682cb036bbd55082cd (diff)
downloadaur-86aeefb9920d066c1b568bd9475b5c4e29aa95af.tar.gz
Update for recent versions
* Remove hacks for Quex, which is no longer used. * Use the new "manage.py" script. * Build and install static libraries, now that the GPRconfig/GPRbuild bug for -r/-pie conflicts is fixed.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 10 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 096d1efb1eb3..0002e42e1577 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pierre-Marie de Rodat <pmderodat on #ada at freenode.net>
pkgname=libadalang-git
-pkgver=r4155.7ddad847
+pkgver=r4370.89d25ed1
pkgrel=1
pkgdesc='High performance syntactic and semantic engine for the Ada programming language'
@@ -30,27 +30,16 @@ build()
{
cd "$srcdir/${pkgname%-git}"
- # In order to build the generated library, Langkit expects the QUEX_PATH to
- # be set.
- source /etc/profile.d/quex.sh
-
- # Clang has trouble compiling the Quex-generated lexer, so make sure
- # GPRbuild chooses GCC.
- gprconfig -o config.cgpr --batch --config=c,,,,GCC --config=ada,,,,
-
- python ada/manage.py --no-langkit-support generate
+ python manage.py generate
# Build Libadalang both as a static library and as a shared one. Ask not to
# use rpath (-R), but that only makes sense for the shared library, so
# build in two steps: once for shared lib (+ mains), and once for static
# lib.
- #
- # TODO: build & install static libraries. For now, this fails because
- # auto-initialized static libraries are built using partial linking (ld's
- # -r option), which conflicts with GCC's by default -pie option.
- python ada/manage.py \
- --library-types relocatable --no-langkit-support \
- build --build-mode=prod --gargs="-R --config=$PWD/config.cgpr"
+ python manage.py build \
+ --library-types static,static-pic,relocatable \
+ --build-mode=prod \
+ --gargs="-R"
}
package()
@@ -58,9 +47,10 @@ package()
cd "$srcdir/${pkgname%-git}"
# Install the Ada library with its C binding
- python ada/manage.py \
- --library-types relocatable --no-langkit-support \
- install --build-mode=prod "$pkgdir/usr"
+ python manage.py install \
+ --library-types static,static-pic,relocatable \
+ --build-mode=prod \
+ "$pkgdir/usr"
# Install the Python binding
cd build/python