summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPierre-Marie de Rodat2018-06-27 19:29:13 +0200
committerPierre-Marie de Rodat2018-06-27 19:29:13 +0200
commit8bd056bcb4d366344c0534f47080ee9ad08892b0 (patch)
tree6d75d799a522082e82c74a89745b946e59cf5aa2 /PKGBUILD
parent366ce638c248a1e816ed8f9a9ab3cd89f94d74ae (diff)
downloadaur-8bd056bcb4d366344c0534f47080ee9ad08892b0.tar.gz
Use gprconfig to make sure we don't use Clang
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69328bec52cd..b0e0a97883b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pierre-Marie de Rodat <pmderodat on #ada at freenode.net>
pkgname=libadalang-git
-pkgver=r2578.e44ddb9d
+pkgver=r2849.99e95476
pkgrel=1
pkgdesc='High performance syntactic and semantic engine for the Ada programming language'
@@ -33,6 +33,10 @@ build()
# be set.
source /etc/profile.d/quex.sh
+ # Clang has trouble compiling the Quex-generated lexer, so make sure
+ # GPRbuild chooses GCC.
+ gprconfig -o config.cgpr --batch --config=c,,,,GCC --config=ada,,,,
+
python2 ada/manage.py --no-langkit-support generate
# Build Libadalang both as a static library and as a shared one. Ask not to
@@ -41,7 +45,7 @@ build()
# lib.
python2 ada/manage.py \
--disable-static --enable-shared --no-langkit-support \
- build --build-mode=prod --gargs="-R"
+ build --build-mode=prod --gargs="-R --config=$PWD/config.cgpr"
# TODO: build & install static libraries. For now, this fails because
# auto-initialized static libraries are built using partial linking (ld's