summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Chudnikov2024-10-07 18:54:02 +0300
committerAlexander Chudnikov2024-10-07 18:54:02 +0300
commit9bd55ca73d8024beeef08be58601226d9f6cf650 (patch)
treeaf04eedfa2eafffb5f0c5c4b3fda3c28c69ae4da /PKGBUILD
downloadaur-9bd55ca73d8024beeef08be58601226d9f6cf650.tar.gz
init(aur): initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..426b69e83721
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Alexander Chudnikov <gi-00001@redline-software.xyz>
+
+pkgname=libakrypt
+pkgver=0.9.15
+pkgrel=1
+pkgdesc="C library implementing key management and Russian national cryptographic standards. It aims to provide an open-source module for cryptographic protection systems, compliant with standard Р 1323565.1.012-2017."
+arch=('x86_32' 'x86_64' 'aarmv7' 'mips' 'mips64')
+url="https://libakrypt.ru/"
+license=('MIT')
+depends=('gcc' 'make' 'cmake' 'git')
+source=("$pkgname::git+https://git.miem.hse.ru/axelkenzo/libakrypt-0.x.git#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ _head_ver=$(grep -oP '(?<=set\s*\(\s*HEAD_VERSION\s*)\d+' CMakeLists.txt)
+ _main_ver=$(grep -oP '(?<=set\s*\(\s*MAIN_VERSION\s*)\d+' CMakeLists.txt)
+ _minor_ver=$(grep -oP '(?<=set\s*\(\s*MINOR_VERSION\s*)\d+' CMakeLists.txt)
+
+ printf '%s.%s.%s' "${_head_ver:?}" "${_main_ver:?}" "${_minor_ver:?}"
+}
+
+build() {
+ cmake -S ./$pkgname -B ./$pkgname/build/ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build ./$pkgname/build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install ./$pkgname/build/
+}